Some starting issues


#1

First off im on the latest/updated version of Mac OSX, on a macbook. I
followed a tutorial…

http://hivelogic.com/articles/2005/12/ruby_rails_lighttpd_mysql_tiger

And then followed the updated one as well and still get issues, i cant
seem to get gem to install correctly? And or install correctly.

I have sort of pin pointed the issue down, i get an error like this each
time i attempt to use gem.

/usr/local/lib/ruby/site_ruby/1.9.0/rubygems/package.rb:386:in
alias_method': undefined methodis_file’ for class
Gem::Package::TarReader::Entry' (NameError) from /usr/local/lib/ruby/site_ruby/1.9.0/rubygems/package.rb:386:inclass:Entry
from /usr/local/lib/ruby/site_ruby/1.9.0/rubygems/package.rb:322:in
<class:TarReader>' from /usr/local/lib/ruby/site_ruby/1.9.0/rubygems/package.rb:310:inmodule:Package
from /usr/local/lib/ruby/site_ruby/1.9.0/rubygems/package.rb:43:in
<top (required)>' from /usr/local/lib/ruby/site_ruby/1.9.0/rubygems/custom_require.rb:27:ingem_original_require’
from
/usr/local/lib/ruby/site_ruby/1.9.0/rubygems/custom_require.rb:27:in
require' from /usr/local/lib/ruby/site_ruby/1.9.0/rubygems/builder.rb:7:in<top (required)>’
from
/usr/local/lib/ruby/site_ruby/1.9.0/rubygems/custom_require.rb:27:in
gem_original_require' from /usr/local/lib/ruby/site_ruby/1.9.0/rubygems/custom_require.rb:27:inrequire’
from /usr/local/lib/ruby/site_ruby/1.9.0/rubygems.rb:110:in
manage_gems' from gem_prelude.rb:182:inmethod_missing’
from /usr/local/bin/gem:10:in `’

I notice it is looking to point to /1.9.0/ but when i browse to that
folder i have 1.8. Is there any way to completely remove these installs?
OR how can I ensure my install goes smooth so I can begin learning…


#2

I’d like to point out when i fresh download Gem, and attempt to run the
setup, i get this error.

bash-3.2$ bash setup.rb
setup.rb: line 13: syntax error near unexpected token (' setup.rb: line 13: config = defined?(RbConfig) ? RbConfig : Config’


#3

Scott Mcleod wrote:

I’d like to point out when i fresh download Gem, and attempt to run the
setup, i get this error.

bash-3.2$ bash setup.rb
setup.rb: line 13: syntax error near unexpected token (' setup.rb: line 13: config = defined?(RbConfig) ? RbConfig : Config’

Don’t you mean to use ruby?

ruby setup.rb


#4

Joel VanderWerf wrote:

Scott Mcleod wrote:

I’d like to point out when i fresh download Gem, and attempt to run the
setup, i get this error.

bash-3.2$ bash setup.rb
setup.rb: line 13: syntax error near unexpected token (' setup.rb: line 13: config = defined?(RbConfig) ? RbConfig : Config’

Don’t you mean to use ruby?

ruby setup.rb

bash-3.2$ ruby setup.rb
/usr/local/lib/ruby/1.9.0/rubygems/requirement.rb:19: warning: already
initialized constant OPS
/usr/local/lib/ruby/1.9.0/rubygems/requirement.rb:29: warning: already
initialized constant OP_RE
/usr/local/lib/ruby/site_ruby/1.9.0/rubygems/specification.rb:24:in
<module:Gem>': Platform is not a module (TypeError) from /usr/local/lib/ruby/site_ruby/1.9.0/rubygems/specification.rb:17:in<top (required)>’
from
/usr/local/lib/ruby/site_ruby/1.9.0/rubygems/package.rb:15:in require' from /usr/local/lib/ruby/site_ruby/1.9.0/rubygems/package.rb:15:in<top
(required)>’
from
/usr/local/lib/ruby/site_ruby/1.9.0/rubygems/builder.rb:7:in require' from /usr/local/lib/ruby/site_ruby/1.9.0/rubygems/builder.rb:7:in<top
(required)>’
from /Users/Scott/rubygems-1.3.1/lib/rubygems.rb:868:in
require' from /Users/Scott/rubygems-1.3.1/lib/rubygems.rb:868:in<top
(required)>’
from gem_prelude.rb:93:in require' from gem_prelude.rb:93:inload_full_rubygems_library’
from gem_prelude.rb:175:in const_missing' from setup.rb:109:in

Still the same error


#5

On Mar 8, 2009, at 21:21, Scott Mcleod wrote:

First off im on the latest/updated version of Mac OSX, on a macbook.

You already have a version of ruby (1.8.6) and RubyGems installed if
you’re on OS X 10.5, /usr/bin/ruby

You’ll want to update RubyGems for Apple’s ruby though.

I have sort of pin pointed the issue down, i get an error like this
each
time i attempt to use gem.

/usr/local/lib/ruby/site_ruby/1.9.0/rubygems/package.rb:386:in
alias_method': undefined methodis_file’ for class
`Gem::package::TarReader::Entry’ (NameError)

1.9.1 is the latest version of ruby and comes with the latest
RubyGems. You probably have a prerelease version of 1.9.0 installed
that has a broken RubyGems.

I imagine that which ruby will report /usr/local/bin/ruby, and ruby -v will report 1.9.0. If you want to use ruby 1.9 you should remove
your current install of 1.9.0 in /usr/local and configure 1.9.1 with
its own suffix:

./configure --program-suffix=19

So you get /usr/local/bin/ruby19 which won’t conflict with the 1.8.6
install you have from Apple.


#6

Eric H. wrote:

On Mar 8, 2009, at 21:21, Scott Mcleod wrote:

First off im on the latest/updated version of Mac OSX, on a macbook.

You already have a version of ruby (1.8.6) and RubyGems installed if
you’re on OS X 10.5, /usr/bin/ruby

You’ll want to update RubyGems for Apple’s ruby though.

I have sort of pin pointed the issue down, i get an error like this
each
time i attempt to use gem.

/usr/local/lib/ruby/site_ruby/1.9.0/rubygems/package.rb:386:in
alias_method': undefined methodis_file’ for class
`Gem::package::TarReader::Entry’ (NameError)

1.9.1 is the latest version of ruby and comes with the latest
RubyGems. You probably have a prerelease version of 1.9.0 installed
that has a broken RubyGems.

I imagine that which ruby will report /usr/local/bin/ruby, and ruby -v will report 1.9.0. If you want to use ruby 1.9 you should remove
your current install of 1.9.0 in /usr/local and configure 1.9.1 with
its own suffix:

./configure --program-suffix=19

So you get /usr/local/bin/ruby19 which won’t conflict with the 1.8.6
install you have from Apple.

bash-3.2$ which ruby
/usr/local/bin/ruby
bash-3.2$ ruby -v
ruby: No such file or directory – 1.9.0 (LoadError)

How would I go about removing ruby? If i try ruby -command- it gives me
this
ruby: No such file or directory – help (LoadError)