Some issues with Ruby


#1

Hi,

I’m having a couple of issues, unfortunately I couldn’t find anything on
the internet. I’m using Ubuntu 7.04, with Ruby 1.8 installed with
Synaptic.

  • My irb doesnt autocomplete objects. When I press TAB, it autocompletes
    paths, but not methods, variables, etc. I have readlines installed.

  • When I want to use Gem packages, I have to “include ‘rubygems’” before
    I can use any package. This wasnt the case in Windows, is it needed in
    Linux? Is there a way to avoid it?

  • rbbr (Ruby Browser) can’t find Gnome/Gtk class documentation. I tried
    both the separate documentation package and downloaded the rbbr with api
    package, but it doesnt show any documentation for Gnome classes. I had
    this problem with all my Ubuntu installations. How can I get Gnome
    classes documented in Ruby Browser?

Thanks


#2

Alexandre R. wrote:

  • My irb doesnt autocomplete objects. When I press TAB, it autocompletes
    paths, but not methods, variables, etc. I have readlines installed.

Use this command:

irb -r irb/completion

OR put this line in your .irbrc file:

require ‘irb/completion’

  • When I want to use Gem packages, I have to “include ‘rubygems’” before
    I can use any package. This wasnt the case in Windows, is it needed in
    Linux? Is there a way to avoid it?

Put

export RUBYOPT=‘rubygems’

in your shell’s env file (.zshenv for me).


#3

Thanks a lot, it all worked very well.

Does anyone know how to fix the Gnome/Gtk documentation?