SMTP settings for action mailer

with rails 2.2.2 action mailer requires a valid ssl certificate
i have a question about routing

my smtp settings for my postfix are now

ActionMailer::Base.smtp_settings = {
:address => “smtp.mydomain.com”,
:port => 25,
:domain => “mydomain.com”,
:authentication => :plain,
:user_name => “[email protected]”,
:password => “password”
}

both the email server and the rails app are on the same machine
if i don’t have the address as 127.0.0.1
is it routing information through the internet instead of internally
in the machine?
if i use 127.0.0.1 i will get the ssl error because the host does not
match up.

Hi,

In your server’s host file map the address smtp.mydomain.com to IP
127.0.0.1
so that it is not routed externally.

-NAYAK

Hi,

I am not sure of using multiple host/domain at a time there
Try just

127.0.0.1 smtp.mydomain.com

NAYAK

I got it to work with the multiple domain names

ActionMailer::Base.smtp_settings = {
:address => “smtp.mydomain.com”,
:port => 25,
:domain => “mydomain.com”,
:authentication => :plain,
:user_name => “[email protected]”,
:password => “password”
}

I have the address as smtp.mydomain.com and it gives 127.0.0.1 in my
mail error log. Instead of ns1.mydomain.com .

Is it working internally now?

From: [email protected]
[mailto:[email protected]] On Behalf Of NAYAK
Sent: Thursday, January 08, 2009 5:34 PM
To: [email protected]
Subject: [Rails] Re: SMTP settings for action mailer

Hi,

I am not sure of using multiple host/domain at a time there
Try just

127.0.0.1 smtp.mydomain.com

NAYAK

On Thu, Jan 8, 2009 at 2:57 PM, Tan YL [email protected] wrote:

I tried changing it to this :

127.0.0.1 localhost.localdomain localhost smtp.mydomain.com smtp

::1 localhost6.localdomain6 localhost6

210.193.49.222 ns1.mydomain.com ns1 localhost smtp.mydomain.com smtp

But it didn’t work

Restarted postfix and mongrel gave ssl error again.

From: [email protected]
[mailto:[email protected]] On Behalf Of NAYAK
Sent: Thursday, January 08, 2009 4:24 PM
To: [email protected]
Subject: [Rails] Re: SMTP settings for action mailer

Hi,

In your server’s host file map the address smtp.mydomain.com to IP
127.0.0.1 so that it is not routed externally.

-NAYAK

On Thu, Jan 8, 2009 at 1:45 PM, tyliong [email protected]n.invalid wrote:

with rails 2.2.2 action mailer requires a valid ssl certificate
i have a question about routing

my smtp settings for my postfix are now

ActionMailer::Base.smtp_settings = {
:address => “smtp.mydomain.com”,
:port => 25,
:domain => “mydomain.com”,
:authentication => :plain,
:user_name => “[email protected]”,
:password => “password”
}

both the email server and the rails app are on the same machine
if i don’t have the address as 127.0.0.1
is it routing information through the internet instead of internally
in the machine?
if i use 127.0.0.1 i will get the ssl error because the host does not
match up.

I tried changing it to this :

127.0.0.1 localhost.localdomain localhost smtp.mydomain.com smtp

::1 localhost6.localdomain6 localhost6

210.193.49.222 ns1.mydomain.com ns1 localhost smtp.mydomain.com smtp

But it didn’t work

Restarted postfix and mongrel gave ssl error again.

From: [email protected]
[mailto:[email protected]] On Behalf Of NAYAK
Sent: Thursday, January 08, 2009 4:24 PM
To: [email protected]
Subject: [Rails] Re: SMTP settings for action mailer

Hi,

In your server’s host file map the address smtp.mydomain.com to IP
127.0.0.1 so that it is not routed externally.

-NAYAK

On Thu, Jan 8, 2009 at 1:45 PM, tyliong [email protected] wrote:

with rails 2.2.2 action mailer requires a valid ssl certificate
i have a question about routing

my smtp settings for my postfix are now

ActionMailer::Base.smtp_settings = {
:address => “smtp.mydomain.com”,
:port => 25,
:domain => “mydomain.com”,
:authentication => :plain,
:user_name => “[email protected]”,
:password => “password”
}

both the email server and the rails app are on the same machine
if i don’t have the address as 127.0.0.1
is it routing information through the internet instead of internally
in the machine?
if i use 127.0.0.1 i will get the ssl error because the host does not
match up.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs