Smtp.gmail.com


#1

I am trying to get my slicehost/Rails/radiant/nginx/mongrel site to work
with the Radiant extension Mailer and smtp.gmail.com

I have the openrain-action_mailer_tls (1.1.3) gem installed.

I have google accounts eMail set up that I can log into so I believe the
user/domain is valid.

I am not sure if I am having a radiant problem or a gMail problem.

Here is the production log…

Processing MailController#create (for 74.184.148.126 at 2009-03-28

17:09:47) [POST] Session ID:
BAh7CToMY3NyZl9pZCIlNzU0MzkzNjgzMjQ2MTE0ZmY0MTRiZjBmZTk0NDZj
NWM6DnJldHVybl90bzAiDHVzZXJfaWRpBiIKZmxhc2hJQzonQWN0aW9uQ29u
dHJvbGxlcjo6Rmxhc2g6OkZsYXNoSGFzaHsGOgtub3RpY2UiJFlvdXIgcGFn
ZSBoYXMgYmVlbiBzYXZlZCBiZWxvdy4GOgpAdXNlZHsGOwhU—26c3f68aca424118bc2aeba2085e34d1e4254765
Parameters: {“action”=>“create”, “page_id”=>“33”,
“mailer”=>{“message”=>“asdasf asfasdf asdasdf asdfasdf asdasdf “,
“name”=>“Bartee L.”, “subject”=>“this is the subject line”,
“email”=>“removed_email_address@domain.invalid”}, “controller”=>“mail”}
Sent mail to removed_email_address@domain.invalid, removed_email_address@domain.invalid

On my dev machine in development mode, it shows the actual eMail
content.

On the slicehost production machine ( as shown above ) it does not.

I required smtp_tls in the config/environment.rb file

I have have this in the config/environment.rb file

ResponseCache.defaults[:directory] =

ActionController::Base.page_cache_directory
ResponseCache.defaults[:logger] = ActionController::Base.logger
ActionMailer::Base.smtp_settings = { :address => “smtp.gmail.com”,
:port => “587”, :domain => “zzzzzz.com”, :user_name =>
“removed_email_address@domain.invalid”, :password => “xxxxxxx”, :authentication => :plain }
end
config.action_mailer.delivery_method = :smtp
config.action_mailer.perform_deliveries = true
config.action_mailer.raise_delivery_errors = true
config.action_mailer.default_charset = ‘utf-8’
end

I am new to this, but have figured out a lot of stuff so far, but I am
baffeled with this….

So any help would be appreciated…