As I continue learning to program, I am finding things I think can
probably be done in a better way. The following code seems like
programmers must run into all the time and I am wondering if there is a
better way to write the code in this situation (it seems very repetitive
to me). I’m having fun and trying to get better at this…
if !session[:subject_id].blank? @subject_id = session[:subject_id] end if !session[:book_id].blank? @book_id = session[:book_id] end if !session[:chapter_id].blank? @chapter_id = session[:chapter_id] end if !session[:section_id].blank? @section_id = session[:section_id] end if !session[:subsection_id].blank? @subsection_id = session[:subsection_id] end if !session[:minisection_id].blank? @minisection_id = session[:minisection_id] end
Is there a better way??