Simple question

I have been having problems getting the audio examples to work from the
command line. I can get the examples to execute by clicking on their
respective GUI icons but when I go to do it from the command line I do
not
hear anything coming out of my speakers.

[email protected]:~/gr-build/gnuradio-examples/python/audio> chmod a+x
dial_tone.py
[email protected]:~/gr-build/gnuradio-examples/python/audio> ./dial_tone.py

[1]+ Stopped ./dial_tone.py

I actually had to press Ctrl Z to stop it because it doesn’t do anything
after I press enter. Anyone have suggestions. I am a newbie and trying
to
figure this out. Thanks.

Newell

On Mon, 2006-09-25 at 05:19 +0000, Newell J. wrote:

I actually had to press Ctrl Z to stop it because it doesn’t do anything
after I press enter. Anyone have suggestions. I am a newbie and trying to
figure this out. Thanks.

Not sure about your audio problem here, but I think you want to be using
CTRL-C to kill your jobs, not CTRL-Z, which suspends your jobs. See:
http://linuxreviews.org/beginner/jobs/

-Lee

On Mon, Sep 25, 2006 at 10:48:50AM -0400, Lee P. wrote:

[1]+ Stopped ./dial_tone.py

I actually had to press Ctrl Z to stop it because it doesn’t do anything
after I press enter. Anyone have suggestions. I am a newbie and trying to
figure this out. Thanks.

Not sure about your audio problem here, but I think you want to be using
CTRL-C to kill your jobs, not CTRL-Z, which suspends your jobs. See:
http://linuxreviews.org/beginner/jobs/

The audio problem could be that some other program has the audio
device open exclusively. This could be a “sound daemon” for your
desktop (e.g., esound or arts). If you’ve got those enabled or
running, try killing them.

Eric

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs