Silverlight (sdlsdk) on mac


#1

Hi

When I want to look at some samples on the mac side of my laptop from
the
sdlsdk I get an error from mono

17:10:27 200 2,527 /samples/ruby/clock/index.html
17:10:27 200 2,397 /samples/ruby/clock/assets/stylesheets/error.css
17:10:27 200 52,969
/samples/ruby/clock/assets/images/silverlight_dusk1_std_1024x768.jpg
17:10:27 500 673 /samples/ruby/clock/app.xap [error generating
XAP:
libMonoPosixHelper.dylib]

Is that something that is fixable ?
I am using the mono 2.0.1 tarball but I get the same problem with trunk
On windows it works when I use mono. Do I submit a bug for that with the
mono team?

Cheers
Ivan


#2

2008/12/6 Ivan Porto C. removed_email_address@domain.invalid:

libMonoPosixHelper.dylib]

Is that something that is fixable ?
I am using the mono 2.0.1 tarball but I get the same problem with trunk
On windows it works when I use mono. Do I submit a bug for that with the
mono team?

This sounds like something similar to http://bugs.debian.org/388369.
Did you compile Mono yourself? If so, make sure zlib is found.

If this is a binary package, packaging bug is in order.


#3

Seo S. wrote:

2008/12/6 Ivan Porto C. removed_email_address@domain.invalid:

Hi

When I want to look at some samples on the mac side of my laptop from
the sdlsdk I get an error from mono
[snip]
If this is a binary package, packaging bug is in order.
On Mac I test with the Mono Mac installer
(http://ftp.novell.com/pub/mono/archive/2.0.1/macos-10-universal/1/MonoFramework-2.0.1_1.macos10.novell.universal.dmg),
and that has always worked.


#4

I had a mono installed with ports too that was the culprit.


#5

I have both … the one i installed from the installer exactly the link
you
gave me Jimmy :slight_smile:
But I also built it from svn in an attempt to make it work. AFAICT zlib
is
properly linked, it is advertised somewhere during the build process.

Ok I will submit a bug report to mono…

Thanks
Ivan

On Fri, Dec 5, 2008 at 6:54 PM, Jimmy S. <