"shoes" issues

So, i have been looking around for easy GUI’s. I tried DL’ing TK but I
got frustrated with the lack of help/ tutorials so i have found the
toolkit “shoes”.
I’m trying to download it, but i get compile errors when trying to run
it, or the “read me”. Is there some other software i need to have one my
PC? I’m not sure if i should be posting this here, but i might as well
give it a shot.
Just in case, yes i have tried other downloads and they arn’t working
either?
Any help would be much appreciated =]

On Tue, Dec 04, 2007 at 01:22:12AM +0900, Erik B. wrote:

if i save them to C: drive and try to run them, cmd says shoes is an
unitialized constant. Is there a way to kind of break free of shoes and
be able to run it with other things like cmd?

So, it sounds like you used the Shoes installer, right? If you look
in C:\Program Files\Common Files\Shoes you should see version 0.r315
installed, is that true?

Open a command prompt and run:

cd C:\Program Files\Common Files\Shoes\0.r315
shoes samples\timer.rb

Does that help any?

_why

Erik B. wrote:

So, i have been looking around for easy GUI’s. I tried DL’ing TK but I
got frustrated with the lack of help/ tutorials so i have found the
toolkit “shoes”.
I’m trying to download it, but i get compile errors when trying to run
it, or the “read me”. Is there some other software i need to have one my
PC? I’m not sure if i should be posting this here, but i might as well
give it a shot.
Just in case, yes i have tried other downloads and they arn’t working
either?
Any help would be much appreciated =]

Ok i have messed around a bit more with this, and now its more
complicated than i thought. I didn’t realized running shoes just does
the open file window. i can run the samples by opening it w/ shoes, but,
if i save them to C: drive and try to run them, cmd says shoes is an
unitialized constant. Is there a way to kind of break free of shoes and
be able to run it with other things like cmd?

On Tue, Dec 04, 2007 at 03:49:44AM +0900, Erik B. wrote:

And yes that works, but its only working when i run them in the sample
folder? is it possible for me to run them in other places?

Sure.

shoes “C:\Program Files\follow.rb”

Here’s a very long command so you can run Shoes from any cmd window:

reg add “HKLM\SYSTEM\ControlSet001\Control\Session
Manager\Environment”
/v Path /t REG_EXPAND_SZ
/d “%Path%;C:\Program Files\Common Files\Shoes\0.r315”

I will add this to the next installer and all thanks to you kind sir.

P. S. Sorry if this is frustrating, just started this whole programming
thing and im trying to get a hang of all the lingo and what not :P!
Thanks for any help

Don’t ever apologize for being new to programming ever again. Now,
I mean it, Erik.

_why

So, it sounds like you used the Shoes installer, right? If you look
in C:\Program Files\Common Files\Shoes you should see version 0.r315
installed, is that true?

Open a command prompt and run:

cd C:\Program Files\Common Files\Shoes\0.r315
shoes samples\timer.rb

Does that help any?

_why

Yes, i used shoes installer, yes i have v. r315 ( and have tried other
versions )
And yes that works, but its only working when i run them in the sample
folder? is it possible for me to run them in other places?
P. S. Sorry if this is frustrating, just started this whole programming
thing and im trying to get a hang of all the lingo and what not :P!
Thanks for any help

Have you considered registering a .shoes extension? “follow.shoes” and
so on?

-mental

_

reg add “HKLM\SYSTEM\ControlSet001\Control\Session
Manager\Environment”
/v Path /t REG_EXPAND_SZ
/d “%Path%;C:\Program Files\Common Files\Shoes\0.r315”

Alright I think the 1st part works, but not the second part, take a look

C:\Documents and Settings\Schmode>reg add
"HKLM\SYSTEM\ControlSet001\Control\Ses
sion

The operation completed successfully

C:\Documents and Settings\Schmode>Manager\Environment"
The system cannot find the path specified.

C:\Documents and Settings\Schmode> /v Path /t REG_EXPAND_SZ
‘/v’ is not recognized as an internal or external command,
operable program or batch file.

C:\Documents and Settings\Schmode> /d “%Path%;C:\Program Files\Common
Files\S
hoes\0.r315”
‘/d’ is not recognized as an internal or external command,
operable program or batch file.

C:\Documents and Settings\Schmode>

Thanks a whole bunch for the help guys!

On Tue, 4 Dec 2007 05:03:18 +0900, Erik B. [email protected]
wrote:

reg add “HKLM\SYSTEM\ControlSet001\Control\Session
Manager\Environment”
/v Path /t REG_EXPAND_SZ
/d “%Path%;C:\Program Files\Common Files\Shoes\0.r315”

Alright I think the 1st part works, but not the second part

Try it all on one line (with spaces in place of line breaks).

-mental

Mental G. wrote:

On Tue, 4 Dec 2007 05:03:18 +0900, Erik B. [email protected]
wrote:

reg add “HKLM\SYSTEM\ControlSet001\Control\Session
Manager\Environment”
/v Path /t REG_EXPAND_SZ
/d “%Path%;C:\Program Files\Common Files\Shoes\0.r315”

Alright I think the 1st part works, but not the second part

Try it all on one line (with spaces in place of line breaks).

-mental

Ahha, thanks, i tried just combining the 2 that didn’t work XD. Thanks a
bunch!!!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs