Setup rails on freebsd

Hello,
I’m migrating some ruby on rails sites from one server to a new one.
(both freebsd 6.x) Rails was setup previously by someone else. I’ve
already installed rubygem rails from ports, and I’m using the same
httpd.conf and httpd-vhosts.conf files from the old machine. when I
transfer over the Ruby sites, all I get is a directory index.
Can anybody suggest where I should start troubleshooting?
Thanks
Ray

Hi rst,

On 5/7/07, rst [email protected] wrote:

transfer over the Ruby sites, all I get is a directory index.
Can anybody suggest where I should start troubleshooting?

Presumably in the log files. Ruby / Rails needs FastCGI (www/fcgi and
www/mod_fastcgi port) with Apache to run, so you might want to check
out, if
your new server has FastCGI support.

I dropped FastCGI in favor of nginx / mongrel a long time ago on my FBSD
boxes, but let me know if you run into trouble.

Regards,
András


András Tarsoly
[email protected]

On Monday 07 May 2007 1:54 am, András Tarsoly wrote:

Hi rst,

On 5/7/07, rst [email protected] wrote:

transfer over the Ruby sites, all I get is a directory index.
Can anybody suggest where I should start troubleshooting?

Presumably in the log files. Ruby / Rails needs FastCGI (www/fcgi and
www/mod_fastcgi port) with Apache to run, so you might want to check out,
if your new server has FastCGI support.
Thank you for your suggestions. I found part of the problem.

problem 1 fixed: document root was incorrect.
mod_fastcgi wasn’t installed, but it wasn’t installed on the old
server
either. The old server seems to be using mod_fcgid.
now, when I go to the URL, I get a 500 error instead of a list of
files.
I’ve included error log exceperts and a little other info below.
Any suggestions on where to go from here?
Thanks, Ray

okay, from errorlogs

[Mon May 07 13:22:19 2007] [warn] mod_fcgid: stderr: DEPRECATION
WARNING:
model is deprecated and will be removed from Rails 2.0 See
http://www.rubyonrails.org/deprecation for details. (called
from /usr/local/www/apache22/data/…/app/controllers/application.rb:
4)
[Mon May 07 13:22:19 2007] [warn] mod_fcgid: stderr: DEPRECATION
WARNING:
depend_on is deprecated and will be removed from Rails 2.0 See
http://www.rubyonrails.org/deprecation for details. (called from
model_without_deprecation
at /usr/local/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/
action_controller/d
[Mon May 07 13:22:19 2007] [warn] mod_fcgid: stderr:
eprecated_dependencies.rb:13)

If I understand, this doesn’t give the cause of the 500 error, it just
tells
me “change your code” ( or don’t upgrade to rails 2.0)

I installed mod_fastcgi and now:
from phpinfo (sorry, I use php, I don’t know Ruby)
under apache modules I get
…mod_fcgid… mod_fastcgi

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs