Setting PythonPath

Hello All,

I have worked on setting the PythonPath for 3 weeks now.

I have followed the steps in the following posting:
http://gnuradio.org/redmine/projects/gnuradio/wiki/UbuntuInstall

Here is my latest attempt of editing my bash file:

GNU Radio installation

export PATH=$PATH:/usr/local
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig
export PYTHONPATH=$PYTHONPATH:/usr/local/lib/python2.6/site-packages

and here is the error code that persists no matter what I do when I use
my benchmark code:

Traceback (most recent call last):
File “benchmark_rx2.6a.py”, line 23, in
from gnuradio import gr, gru, modulation_utils
ImportError: No module named gnuradio

Does anyone have any tips or clues as to what I am doing wrong?

Aaron henderson


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

My suggestion was probably unnecessarily complicating things.

You need to find where the gnuradio has been installed to. There will
be a directory containing a gnuradio folder which in turn will contain
an init.py file.
You could find it by brute force using something like:
find / -name “gnuradio” 2>/dev/null | xargs -I{} find ‘{}’ -maxdepth 1
-name “init.py”

If you’re sure you’ve got the correct location then you’re likely not
setting your PYTHONPATH like you think you are. Trying doing it
manually in a shell. Run python from that shell and see if you can
import gnuradio.

Also, as of a couple of weeks ago, if you put
gnuradio/build/gnuradio-runtime/python in your PYTHONPATH then that
will work too. You’ll need to be using the current master branch for
this to work.

I installed gnuradio c from the script , but there is error about
pythonpath
how configure the enveronment on Mint15

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs