Setting button colour on 1.9.5

Hi all,

i’m working with wxruby 1.9.5 on windows.
Trying to set the background colour for a button does not work!

Thanks for any help,
Franz


This communication and any files or attachments transmitted with it may
contain information that is copyrighted or confidential and exempt from

disclosure under applicable law. It is intended solely for the use
of the individual or the entity to which it is addressed.

If you are not the intended recipient, you are hereby notified that any
use, dissemination, or copying of this communication is strictly
prohibited.

If you have received this communication in error, please notify us at
once so that we may take the appropriate action and avoid troubling you
further.

Thank you for your cooperation. Please contact your local IT staff or
email [email protected]
if you need assistance.

 

Siltronic AG, Sitz München, Hanns-Seidel-Platz 4, 81737
München, Germany. Amtsgericht München HRB 150884


Vorstand: Wilhelm Sittenthaler (Vorsitz), Gerhard Brehm, Paul Lindblad,
Joachim Manke, Michael Peterat. Vorsitzender des Aufsichtsrats:
Peter-Alexander Wacker

Hi Franz

Irlweg, Franz (ZNT) wrote:

i’m working with wxruby 1.9.5 on windows.
Trying to set the background colour for a button does not work!

The background colour for a standard OS button will come from the user’s
desktop theme. Because these are native widgets, on most desktops this
standard colour can’t be changed - this is a feature not a bug :wink: as it
keeps applications consistent with respective GUI standards.

If you really must have multi-coloured buttons, use Wx::BitmapButton.

hth
alex

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs