Serving public images


#1

hi,

i’m a newbie on the radiant front. got a q on images. i’ve created a
stylesheet using a page with a content type of text/css with <r:content
/> as the body. its published and the css is working fine.
the only issue i have is where i want to use a tiled image for a faux
column layout. when i reference the image in the css it doesnt render.

#wrap
{
max-width: 1200px;
min-width: 750px;
background: url(’/images/wrap-background.jpg’) repeat-y 70% 0;
}

i’ve placed the image in the public/images folder.

when i try to get the image directly i get a 404, is there some way for
me to get radiant to server the image directly. i saw in the admin for
example it uses /images/admin/image.png?12345.

at this stage i’m just trying to get up and running with something
simple.
any help is much appreciated.

regads.


#2

On Oct 17, 2008, at 8:07 PM, Michael D. wrote:

{
example it uses /images/admin/image.png?12345.

at this stage i’m just trying to get up and running with something
simple.
any help is much appreciated.

regads.

Are you certain that this image exists on the server where you expect
it?
Judging by the fact that you get a 404 when trying to access it, I’d
guess that it does not exist where you expect.
Do other images work on your site where you might use ?


#3

On Oct 17, 2008, at 8:07 PM, Michael D. wrote:

{
example it uses /images/admin/image.png?12345.

at this stage i’m just trying to get up and running with something
simple.
any help is much appreciated.

regads.

Are you certain that this image exists on the server where you expect
it?
Judging by the fact that you get a 404 when trying to access it, I’d
guess that it does not exist where you expect.
Do other images work on your site where you might use ?


#4

i restarted the script/server and it worked… dont ask me how…
this is what happens after 10 coffees at 2am…
:-o

thanks for the input…