Server won't start!


#1

Hello,
I’ve got an InstantRails 1.7 app (ruby 1.86, rails 2.1.0) that will no
longer start since I rebooted my windows server 2003 machine to complete
some windows updates. However, I also deleted some gems earlier today,
but it started right up perfectly fine. Anyway, here is whats happening:

C:\InstantRails\rails_apps\dejavu>ruby script/server
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.1.0 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
Exiting
C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/mon
grel/tcphack.rb:12:in `initialize_without_backlog’: Bad file descriptor

  • bind(2
    ) (Errno::EBADF)
    from
    C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin
    32-60/lib/mongrel/tcphack.rb:12:in initialize' from C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin 32-60/lib/mongrel.rb:93:innew’
    from
    C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin
    32-60/lib/mongrel.rb:93:in initialize' from C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin 32-60/lib/mongrel/configurator.rb:139:innew’
    from
    C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin
    32-60/lib/mongrel/configurator.rb:139:in listener' from C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin 32-60/bin/mongrel_rails:99:incloaker_’
    from
    C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin
    32-60/lib/mongrel/configurator.rb:50:in call' from C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin 32-60/lib/mongrel/configurator.rb:50:ininitialize’
    … 14 levels…
    from
    C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/command
    s/server.rb:39
    from
    C:/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require
    .rb:27:in gem_original_require' from C:/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require .rb:27:inrequire’
    from script/server:3

I tried reinstalling the mongrel gem, but that didn’t work. Anybody know
whats going on??

Any and all help is appreciated!!

  • Jeff M.

#2

Nevermind, I forgot I had a windows scheduled task to start the server
on start up - the server is already up, that’s why its getting all
confused… my bad for wasting a post, guys.