Server not starting


#1

Hey guys,

I cant seem to start my rails server anymore. I have been working with
no issue for about a week and then my project has stopped working. I
suspect an issue with the ruby gems system. Here is the stack trace i
get when i try and run script server…

/Users/portablelaptop/Workspace/blueprint/config/environment.rb:45:
You have a nil object when you didn’t expect it! (NoMethodError)
You might have expected an instance of ActiveRecord::Base.
The error occurred while evaluating nil.[]
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:in gem_original_require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:27:inrequire’
from /Users/portablelaptop/Workspace/blueprint/vendor/rails/
activesupport/lib/active_support/dependencies.rb:510:in require' from /Users/portablelaptop/Workspace/blueprint/vendor/rails/ activesupport/lib/active_support/dependencies.rb:355:innew_constants_in’
from /Users/portablelaptop/Workspace/blueprint/vendor/rails/
activesupport/lib/active_support/dependencies.rb:510:in require' from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../ lib/mongrel/rails.rb:147:inrails’
from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:113:in cloaker_' from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/lib/ mongrel/configurator.rb:149:incall’
from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/lib/
mongrel/configurator.rb:149:in listener' from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/ mongrel_rails:99:incloaker_’
from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/lib/
mongrel/configurator.rb:50:in call' from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/lib/ mongrel/configurator.rb:50:ininitialize’
from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:84:in new' from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/ mongrel_rails:84:inrun’
from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/lib/
mongrel/command.rb:212:in run' from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/ mongrel_rails:281 from /Users/portablelaptop/Workspace/blueprint/vendor/rails/ activesupport/lib/active_support/dependencies.rb:503:inload’
from /Users/portablelaptop/Workspace/blueprint/vendor/rails/
activesupport/lib/active_support/dependencies.rb:503:in load' from /Users/portablelaptop/Workspace/blueprint/vendor/rails/ activesupport/lib/active_support/dependencies.rb:355:innew_constants_in’
from /Users/portablelaptop/Workspace/blueprint/vendor/rails/
activesupport/lib/active_support/dependencies.rb:503:in load' from /Users/portablelaptop/Workspace/blueprint/vendor/rails/ railties/lib/commands/servers/mongrel.rb:64 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:27:ingem_original_require’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:in require' from /Users/portablelaptop/Workspace/blueprint/vendor/rails/ activesupport/lib/active_support/dependencies.rb:510:inrequire’
from /Users/portablelaptop/Workspace/blueprint/vendor/rails/
activesupport/lib/active_support/dependencies.rb:355:in
new_constants_in' from /Users/portablelaptop/Workspace/blueprint/vendor/rails/ activesupport/lib/active_support/dependencies.rb:510:inrequire’
from /Users/portablelaptop/Workspace/blueprint/vendor/rails/
railties/lib/commands/server.rb:39
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:in gem_original_require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:27:inrequire’
from script/server:3


#2

On Mon, Oct 20, 2008 at 2:20 AM, Stewart
removed_email_address@domain.invalid wrote:

/Users/portablelaptop/Workspace/blueprint/config/environment.rb:45:
You have a nil object when you didn’t expect it! (NoMethodError)

Can you post line 45 of

/Users/portablelaptop/Workspace/blueprint/config/environment.rb