Server error

Hi, I’m new to rails. I installed it according to “getting started”,
created new application, run the server… and got an error :frowning:

C:\Temp\RailsApplication1>ruby script/server
=> Booting WEBrick
=> Rails 2.3.5 application starting on http://0.0.0.0:3000
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/initializer.rb:
271:in rescue in require_frameworks': no such file to load -- jopenssl (RuntimeError) from C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/ initializer.rb:2 68:inrequire_frameworks’
from C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/
initializer.rb:1
34:in process' from C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/ initializer.rb:1 13:inrun’
from C:/Temp/RailsApplication1/config/environment.rb:9:in
<top (require d)>' from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/ lib/active_s upport/dependencies.rb:156:inrequire’
from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/
lib/active_s
upport/dependencies.rb:156:in block in require' from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/ lib/active_s upport/dependencies.rb:521:innew_constants_in’
from C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/
lib/active_s
upport/dependencies.rb:156:in require' from C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/ commands/server. rb:84:in<top (required)>’
from script/server:3:in require' from script/server:3:in

My system:
Windows XP SP3
Ruby 1.9.1
Rails 2.3.5
MySQL 5.1

Can anyone help?

Install the “jruby-openssl” gem and then try.

I tryed, it didn’t help.
I uninstalled Ruby and instaled older version - 1.8.7, and there it
works :slight_smile:
Of course now I’ve got other problems, but mabey it’s Rubys 1.9.1 bug,
or
something