Segmentation fault while running tests for latest Rails 4.2

Hi All,

I am trying to build Rails from source for the latest stable (4.2)
version
from the branch 4-2-stable; however I am facing issue while running the
tests.

I am getting a segmentation fault at ‘activesupport’ for rake tests.

Has anyone already seen this error before? Can someone help me fix this
test-case?

The details of error log are as below:

Platform I am trying on: Ubuntu 14.10

Rails Version: 4.2.3

Ruby Version: 2.2.2 & 2.1.6 (on both versions getting same trace)

Command used:

$ bundle exec rake test --trace

====================

** Invoke test (first_time)

** Execute test

/home/test/.rvm/rubies/ruby-2.1.6/bin/ruby -w -I"lib:test"
-I"/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib"
“/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/rake_test_loader.rb”
“test/**/*_test.rb”

Run options: --seed 36135

Running:


Segmentation fault

rake aborted!

Command failed with status (139): [ruby -w -I"lib:test"
-I"/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib"
“/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/rake_test_loader.rb”
“test/**/*_test.rb” ]

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/testtask.rb:108:in
`block (3 levels) in define’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/file_utils.rb:57:in
`call’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/file_utils.rb:57:in
`sh’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/file_utils_ext.rb:37:in
`sh’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/file_utils.rb:96:in
`ruby’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/file_utils_ext.rb:37:in
`ruby’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/testtask.rb:104:in
`block (2 levels) in define’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/file_utils_ext.rb:58:in
`verbose’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/testtask.rb:100:in
`block in define’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/task.rb:240:in
`call’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/task.rb:240:in
`block in execute’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/task.rb:235:in
`each’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/task.rb:235:in
`execute’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/task.rb:179:in
`block in invoke_with_call_chain’

/home/test/.rvm/rubies/ruby-2.1.6/lib/ruby/2.1.0/monitor.rb:211:in
`mon_synchronize’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/task.rb:172:in
`invoke_with_call_chain’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/task.rb:165:in
`invoke’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/application.rb:150:in
`invoke_task’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/application.rb:106:in
`block (2 levels) in top_level’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/application.rb:106:in
`each’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/application.rb:106:in
`block in top_level’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/application.rb:115:in
`run_with_threads’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/application.rb:100:in
`top_level’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/application.rb:78:in
`block in run’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/application.rb:176:in
`standard_exception_handling’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/lib/rake/application.rb:75:in
`run’

/home/test/.rvm/gems/ruby-2.1.6/gems/rake-10.4.2/bin/rake:33:in `<top
(required)>’

/home/test/.rvm/gems/ruby-2.1.6/bin/rake:23:in `load’

/home/test/.rvm/gems/ruby-2.1.6/bin/rake:23:in `’

/home/test/.rvm/gems/ruby-2.1.6/bin/ruby_executable_hooks:15:in `eval’

/home/test/.rvm/gems/ruby-2.1.6/bin/ruby_executable_hooks:15:in `’

Tasks: TOP => test

[email protected]:~/meghali/rails-4.2.3/rails/activesupport$

[email protected]:~/meghali/rails-4.2.3/rails/activesupport$
[email protected]:~/meghali/rails-4.2.3/rails/active

Thanks in advance.

In addition to the above details, I would like to mention that I am
getting
this issue on Power system(ppc64le).

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs