Segmantation fault usrp_spectrum_sense

last week every thing was fine until today when i want to sense the
spectrum i faced this problem

./usrp_spectrum_sense.py 1901M 1983M > file.tr

Warning: this is known to have issues on some machines+Python version
combinations to seg fault due to the callback in bin_statitics. If
you
figure out why, we’d love to hear about it!
Traceback (most recent call last):
File “./usrp_spectrum_sense.py”, line 237, in
tb = my_top_block()
File “./usrp_spectrum_sense.py”, line 135, in init
num_channels=1)
File “/usr/local/lib/python2.7/
dist-packages/gnuradio/uhd/init.py”,
line 116, in constructor_interceptor
return old_constructor(*args)
File
“/usr/local/lib/python2.7/dist-packages/gnuradio/uhd/uhd_swig.py”,
line 2885, in usrp_source
return _uhd_swig.usrp_source(*args)
RuntimeError: LookupError: KeyError: No devices found for ----->
Device Address:
addr: 192.168.10.2
although i am using usrp 1 so i added this args

usrp_spectrum_sense.py 1901M 1983M >file.tr --address=“type=usrp1”

linux; GNU C++ version 4.6.1; Boost_104601;
UHD_003.004.000-24-g8630807c

Warning: this is known to have issues on some machines+Python version
combinations to seg fault due to the callback in bin_statitics. If
you
figure out why, we’d love to hear about it!
– Opening a USRP1 device…
– Using FPGA clock rate of 64.000000MHz…
Using Volk machine: ssse3_64
gain = 25.75
Segmentation fault

On Sun, Apr 8, 2012 at 9:59 PM, Abdelrahman A. [email protected]
wrote:

File “./usrp_spectrum_sense.py”, line 135, in init
addr: 192.168.10.2
Using Volk machine: ssse3_64
gain = 25.75
Segmentation fault

Well, it does say right as you start the program:

Warning: this is known to have issues on some machines+Python version
combinations to seg fault due to the callback in bin_statitics. If
you
figure out why, we’d love to hear about it!

So what changed for you between last week and this week? Have you
changed code or any installations that we should know about?

Tom

No thing happened all other examples are working .
When i added “file.tr” to the command it gave me this error and when i
wrote the command without “file.tr” it worked without any problems and
usrp
start to sense.
But i need to save this data