Seg fault, ferret 0.10.11

Hi, we’re using Ferret 0.10.11 with acts_as_ferret (stable from svn), on
a unix box, running rails 1.1.6 in production. a few days ago i rebuilt
the index (by deleting the previous one and letting acts_as_ferret do
its thing), and it ran fine for a few days. this evening i got a seg
fault when one of the indexes was being updated via aaf, and now all
ferret searches are busted, returning this error:

EOFError (End-of-File Error occured at <except.c>:79 in xraise
Error occured in compound_io.c:123 - cmpdi_read_i
Tried to read past end of file. File length is <86> and tried to
read to <164>

):

We had a similar problem last week, and I had hoped that upgrading from
0.10.1 to 0.10.11 would fix it, but apparently not.

we have 36 models using acts_as_ferret, each with a separate index.
between them all there are about 13,000 items in the index.

i’m going to rebuild the index again, which seems to fix this
temporarily, but i’d really love to figure out what’s causing it and fix
the problem. any help gratefully appreciated.

thanks, john

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs