Script/server error

Not sure why I’m getting this error, cause I believe it worked
yesterday before I quit and now it’s giving me this error. The last
thing I did was try and get an ActionMailer thing to work. I searched
through the archives but nothing seemed applicable to my error.
Here’s the error I’m getting:

ruby script/server
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.1.0 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
Exiting
C:/Ruby/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.0/lib/
active_support/depen
dencies.rb:492:in const_missing': uninitialized constant CGI::Session::ActiveRe cordStore (NameError) from C:/Ruby/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.0/lib/ action_con troller/session_management.rb:26:inconst_get’
from C:/Ruby/ruby/lib/ruby/gems/1.8/gems/actionpack-2.1.0/lib/
action_con
troller/session_management.rb:26:in session_store=' from C:/Ruby/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/ initializer.rb: 455:insend’
from C:/Ruby/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/
initializer.rb:
455:in initialize_framework_settings' from C:/Ruby/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/ initializer.rb: 454:ineach’
from C:/Ruby/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/
initializer.rb:
454:in initialize_framework_settings' from C:/Ruby/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/ initializer.rb: 451:ineach’
from C:/Ruby/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/
initializer.rb:
451:in initialize_framework_settings' ... 30 levels... from C:/Ruby/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/ commands/server .rb:39 from C:/Ruby/ruby/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:27:i ngem_original_require’
from C:/Ruby/ruby/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:i
n `require’
from script/server:3


I haven’t touched anything in those directories, so I’m not entirely
sure why it’s doing that.

Help?

On Jul 8, 3:33 pm, Camel [email protected] wrote:

I haven’t touched anything in those directories, so I’m not entirely
sure why it’s doing that.

Help?

Looks like something to do with the session settings in environment.rb

Fred

Here’s my environment.rb file:

Be sure to restart your server when you modify this file

Uncomment below to force Rails into production mode when

you don’t control web/app server and can’t set it the proper way

ENV[‘RAILS_ENV’] ||= ‘production’

Specifies gem version of Rails to use when vendor/rails is not

present
RAILS_GEM_VERSION = ‘2.1.0’ unless defined? RAILS_GEM_VERSION

Bootstrap the Rails environment, frameworks, and default

configuration
require File.join(File.dirname(FILE), ‘boot’)

Rails::Initializer.run do |config|

Settings in config/environments/* take precedence over those

specified here.

Application configuration should go into files in config/

initializers

– all .rb files in that directory are automatically loaded.

See Rails::Configuration for more options.

Skip frameworks you’re not going to use. To use Rails without a

database

you must remove the Active Record framework.

config.frameworks -=
[ :active_record, :active_resource, :action_mailer ]

Specify gems that this application depends on.

They can then be installed with “rake gems:install” on new

installations.

config.gem “bj”

config.gem “hpricot”, :version => ‘0.6’, :source => "http://

code.whytheluckystiff.net"

config.gem “aws-s3”, :lib => “aws/s3”

Only load the plugins named here, in the order given. By default,

all plugins

in vendor/plugins are loaded in alphabetical order.

:all can be used as a placeholder for all plugins not explicitly

named

config.plugins =

[ :exception_notification, :ssl_requirement, :all ]

Add additional load paths for your own custom dirs

config.load_paths += %W( #{RAILS_ROOT}/extras )

Force all environments to use the same logger level

(by default production uses :info, the others :debug)

config.log_level = :debug

Make Time.zone default to the specified zone, and make Active

Record store time values

in the database in UTC, and return them converted to the specified

local zone.

Run “rake -D time” for a list of tasks for finding time zone

names. Uncomment to use default local time.
config.time_zone = ‘UTC’

Your secret key for verifying cookie session data integrity.

If you change this key, all old sessions will become invalid!

Make sure the secret is at least 30 characters and all random,

no regular words or you’ll be exposed to dictionary attacks.

config.action_controller.session = {
:session_key => ‘_theatre_session’,
:secret =>
‘ae40239837165baa87c29a1c0a14ec1e59e09fc7e99186f3b27b2bb1c8c94d02829388dcc4d7ad263e589a8359c28fcb8fa94901de4da81949b77a2847fadbc7’
}

Use the database for sessions instead of the cookie-based default,

which shouldn’t be used to store highly confidential information

(create the session table with “rake db:sessions:create”)

config.action_controller.session_store = :active_record_store

Use SQL instead of Active Record’s schema dumper when creating the

test database.

This is necessary if your schema can’t be completely dumped by the

schema dumper,

like if you have constraints or database-specific column types

config.active_record.schema_format = :sql

Activate observers that should always be running

config.active_record.observers = :cacher, :garbage_collector

end

Skip frameworks you’re not going to use. To use Rails without a

database

you must remove the Active Record framework.

config.frameworks -=
[ :active_record, :active_resource, :action_mailer ]

Use the database for sessions instead of the cookie-based default,

which shouldn’t be used to store highly confidential information

(create the session table with “rake db:sessions:create”)

config.action_controller.session_store = :active_record_store


I’ve got :active_record loaded… or am I missing something?

On 8 Jul 2008, at 15:44, Camel wrote:

config.action_controller.session_store = :active_record_store
You can’t used the active_record_store if you’re not loading
ActiveRecord.

Fred

Oh. Well, now that makes a lot more sense. I’ll try that and get
back to you.

On Jul 8, 12:16 pm, Frederick C. [email protected]

On 8 Jul 2008, at 17:09, Camel wrote:

Use the database for sessions instead of the cookie-based default,

which shouldn’t be used to store highly confidential information

(create the session table with “rake db:sessions:create”)

config.action_controller.session_store = :active_record_store

I’ve got :active_record loaded… or am I missing something?

No you haven’t: you’re removing active_record, active_resource,
action_mailer from the list of frameworks to load

Fred

That seemed to work. I’m not sure why it did, cause I never messed
with the config.framework thing before… not that i recall anyway.

Thanks Fred.

-Camel

On Jul 8, 12:16 pm, Frederick C. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs