Script/process/reaper: No such file or directory

Hi all

I’m trying to deploy an app using Capistrano. So far so good, everything
works quite fine, except restarting the application. I guess it has
something to do with the output

script/process/reaper: No such file or directory.

The whole output is:

192:trunk josh$ cap deploy:migrations

  • executing `deploy:migrations’
  • executing `deploy:update_code’
    executing locally: “svn info http://??? --username incense
    –password ??? --no-auth-cache -rHEAD”
    /usr/local/bin/svn
  • executing "svn export -q --username incense --password ???
    –no-auth-cache -r6 http://???
    /home/incensec/railsapps/cap/incense/releases/20091021191619 && (echo 6

/home/incensec/railsapps/cap/incense/releases/20091021191619/REVISION)"
servers: [“incense.ch”]
Password:
[incense.ch] executing command
command finished

  • executing `deploy:finalize_update’
  • executing “chmod -R g+w
    /home/incensec/railsapps/cap/incense/releases/20091021191619”
    servers: [“incense.ch”]
    [incense.ch] executing command
    command finished
  • executing “rm -rf
    /home/incensec/railsapps/cap/incense/releases/20091021191619/log
    /home/incensec/railsapps/cap/incense/releases/20091021191619/public/system
    /home/incensec/railsapps/cap/incense/releases/20091021191619/tmp/pids
    &&\\n mkdir -p
    /home/incensec/railsapps/cap/incense/releases/20091021191619/public
    &&\\n mkdir -p
    /home/incensec/railsapps/cap/incense/releases/20091021191619/tmp &&\\n
    ln -s /home/incensec/railsapps/cap/incense/shared/log
    /home/incensec/railsapps/cap/incense/releases/20091021191619/log &&\\n
    ln -s /home/incensec/railsapps/cap/incense/shared/system
    /home/incensec/railsapps/cap/incense/releases/20091021191619/public/system
    &&\\n ln -s /home/incensec/railsapps/cap/incense/shared/pids
    /home/incensec/railsapps/cap/incense/releases/20091021191619/tmp/pids”
    servers: [“incense.ch”]
    [incense.ch] executing command
    command finished
  • executing “find
    /home/incensec/railsapps/cap/incense/releases/20091021191619/public/images
    /home/incensec/railsapps/cap/incense/releases/20091021191619/public/stylesheets
    /home/incensec/railsapps/cap/incense/releases/20091021191619/public/javascripts
    -exec touch -t 200910211916.32 {} ‘;’; true”
    servers: [“incense.ch”]
    [incense.ch] executing command
    ** [out :: incense.ch] sh: /usr/bin/find: Permission denied
    command finished
  • executing `after_update_code’
  • executing “ln -nfs
    /home/incensec/railsapps/cap/incense/shared/config/database.yml
    /home/incensec/railsapps/cap/incense/releases/20091021191619/config/database.yml”
    servers: [“incense.ch”]
    [incense.ch] executing command
    command finished
  • executing `deploy:migrate’
  • executing “ls -xt /home/incensec/railsapps/cap/incense/releases”
    servers: [“incense.ch”]
    [incense.ch] executing command
    command finished
  • executing “cd
    /home/incensec/railsapps/cap/incense/releases/20091021191619; rake
    RAILS_ENV=production db:migrate”
    servers: [“incense.ch”]
    [incense.ch] executing command
    ** [out :: incense.ch] (in
    /home/incensec/railsapps/cap/incense/releases/20091021191619)
    command finished
  • executing `deploy:symlink’
  • executing “rm -f /home/incensec/railsapps/cap/incense/current && ln
    -s /home/incensec/railsapps/cap/incense/releases/20091021191619
    /home/incensec/railsapps/cap/incense/current”
    servers: [“incense.ch”]
    [incense.ch] executing command
    command finished
  • executing deploy:restart' [DEPRECATED]deploy:restart` is going to be changed to Passenger
    mod_rails’ method after 2.5.9 - see http://is.gd/2BPeA
  • executing
    “/home/incensec/railsapps/cap/incense/current/script/process/reaper”
    servers: [“incense.ch”]
    [incense.ch] executing command
    ** [out :: incense.ch] sh:
    /home/incensec/railsapps/cap/incense/current/script/process/reaper: No
    such f
    ** [out :: incense.ch] ile or directory
    command finished
    192:trunk josh$

Anyone knows how to fix this. I use use_sudo = false…

Thanks a lot
Josh

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs