Scaffold 'destroy' method not working?

My destroy method, which I screated from a rails scaffold, isn’t
working. I even went as far as to overwrite the entire controller in
hopes that I had really messed up and not realized it, but alas,
nothing changed. What could be the possible cause of this?

hello i have the same problem

it does not work on windows neither on a centos setup

i have no idea why it does this ???

what is in your logging file?


Heri R.
http://sprinj.com

I am having the same problem, on a windows computer as well.

Haven’t solved it yet.

Processing ClientsController#destroy (for 127.0.0.1 at 2006-10-07
16:32:08) [GET]
Session ID: 1e6ceb5ab77ad8a5bf5796f00e47cd65
Parameters: {“post”=>“true”, “action”=>“destroy”, “id”=>“5”,
“controller”=>“clients”}
Redirected to http://localhost:3000/clients/list
Filter chain halted as
[#Proc:[email protected]:/RUBYDE~1/ruby/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/verification.rb:64]
returned false
Completed in 0.00010 (10000 reqs/sec) | DB: 0.00000 (0%) | 302 Found
[http://localhost/clients/destroy/5?post=true]

I have set Destory to Post and it still doesnt work.

Also I tried to see if the destory was even being called and it doesnt
look like it

def destroy
flash[:notice]=“Called!”
if request.post?
Client.find(params[:id]).destory
redirect_to :action => ‘list’
else
flash[:notice]=“illegal delete call”
end
end
end

because it would flash me and it doesnt.

What could this mean?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs