Saluti e presentazione

Ciao a tutti,

Piacere mi presento sono tele.
Dal python son passato al ruby ed e’ nato un amore, ormai e’ un po’ di
tempo che lo uso.
Lavoro nel campo TLC e dove posso cerco di usare Ruby/Rails quando mi e’
possibile.

mi fa piacere che esista questa lista in cui i rubysti italiani possano
discutere :wink:

:tele

benvenuto :]

----- Original Message -----
From: “tele” [email protected]
To: [email protected]
Sent: Tuesday, July 25, 2006 10:39 AM
Subject: [ruby-it] saluti e presentazione

:tele



Ml mailing list
[email protected]
http://lists.ruby-it.org/mailman/listinfo/ml

Salve a tutti
sto cercando di imparare rails e ho cercato di installare postgres su
ubuntu 6.06
digitando:
sudo gem install postgres
ricevo molti errori del tipo di quelli riportati sotto (ne riporto solo
alcuni, ne ricevo qualche centinaio):

postgres.c:1418: error: â??CONNECTION_OKâ?? undeclared (first use in this
function)
postgres.c:1419: error: â??CONNECTION_BADâ?? undeclared (first use in this
function)
postgres.c:1476: error: â??INV_WRITEâ?? undeclared (first use in this
function)
postgres.c:1477: error: â??INV_READâ?? undeclared (first use in this
function)
postgres.c:1486: error: â??PGRES_EMPTY_QUERYâ?? undeclared (first use in
this function)
postgres.c:1487: error: â??PGRES_COMMAND_OKâ?? undeclared (first use in this
function)

alla fine ricevo il messaggio:
Successfully installed postgres-0.7.1

ma davvero è tutto a posto, dopo tutti questi errori? E se è così,
dove sono i file eseguibili?

Grazie a tutti e scusate per l’ignoranza
Marco

Dubito (ma non ci giuro) che si possa installare postgres via gem.
Quelli che hai installato sono probabilmente i driver ruby per postgres.

Immagino che tu debba installare postgres da un pacchetto specifico per
la
tua distro con apt-get, smart o simili (ubuntu usa i .deb?)

Paolo

On 7/25/06, Marco L. [email protected] wrote:

function)

Ml mailing list
[email protected]
http://lists.ruby-it.org/mailman/listinfo/ml


Paolo D.’
SeeSaw | Another point of view


[email protected]

2006/7/26, Marco L. [email protected]:

Il giorno mer, 26/07/2006 alle 10.42 +0200, Paolo Donà ha scritto:

Dubito (ma non ci giuro) che si possa installare postgres via gem.
Quelli che hai installato sono probabilmente i driver ruby per postgres.

Immagino che tu debba installare postgres da un pacchetto specifico per la
tua distro con apt-get, smart o simili (ubuntu usa i .deb?)

Paolo
In realtà postgres si installa via gem, ma a me, per qualche motivo, non
funziona. In ogni caso ho risolto più o meno come mi hai consigliato,

Curiosità: scusa se mi intrometto, ma dove hai trovato il gem di postgres
?


Michele F.
SeeSaw | Another point of view


[email protected]

Il giorno mer, 26/07/2006 alle 10.42 +0200, Paolo Donà ha scritto:

Dubito (ma non ci giuro) che si possa installare postgres via gem.
Quelli che hai installato sono probabilmente i driver ruby per postgres.

Immagino che tu debba installare postgres da un pacchetto specifico per la
tua distro con apt-get, smart o simili (ubuntu usa i .deb?)

Paolo
In realtà postgres si installa via gem, ma a me, per qualche motivo, non
funziona. In ogni caso ho risolto più o meno come mi hai consigliato,
installando postgres dai sorgenti e ruby-postgre via gem, e sembra
funzionare.
Grazie comunque per l’attenzione
Marco

Curiosità : scusa se mi intrometto, ma dove hai trovato il gem di postgres ?

In effetti non lo so (e mi scuso ancora per l’ignoranza). Quando faccio:
gem install postgres
il programma sembra installarsi, e alla fine il messaggio che ottengo è:
Successfully installed postgres-0.7.1
anche se in realtà non si è installato correttamente. Perciò ho pensato
che la possibilità di installare postgres via gem ci sia, ma forse mi
sono sbagliato. Se servono altre informazioni, a disposizione.
Marco

Il 26-07-2006 Paolo Donà ha scritto:

Immagino che tu debba installare postgres da un pacchetto specifico
per la
tua distro con apt-get, smart o simili (ubuntu usa i .deb?)

E forse ci vuole anche qualche sistema per avere i sorgenti (si Ubuntu
usa deb)


blog: http://www.akropolix.net/rik0/blogs | Enrico F.
site: http://www.akropolix.net/rik0/ | RiK0
forum: http://www.akropolix.net/forum/ | Linux Counter: #299198

2006/7/26, Marco L. [email protected]:

Curiosità: scusa se mi intrometto, ma dove hai trovato il gem di postgres ?

In effetti non lo so (e mi scuso ancora per l’ignoranza). Quando faccio:
gem install postgres
il programma sembra installarsi, e alla fine il messaggio che ottengo è:
Successfully installed postgres-0.7.1
anche se in realtà non si è installato correttamente. Perciò ho pensato
che la possibilità di installare postgres via gem ci sia, ma forse mi
sono sbagliato. Se servono altre informazioni, a disposizione.

come pensavo: quello che installi via gem è il ‘driver’ ruby per il
database
coem si vede da qui http://ruby.scripting.ca/postgres/
mentre il DB vero e proprio devi installarlo (e scaricarlo a parte) per
sempio
da qui http://www.postgresql.org/ftp/
come puoi vedere dai numeri di versione no è il DB quelo che ottieni
tramite
gem :wink:


Michele F.
SeeSaw | Another point of view


[email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs