SaltedHashLoginGenerator Verification Trouble


#1

Hello all,

Any help with this one is MUCH appreciated. I am running Ruby 1.84 and
Rails 1.1.0 on Win32 with a local SMTP server. I can successfully send a
signup confirmation email with a confirmation link, but when I click on
the link, it says that I am logged in, but it never verifies the
account. This is the link provided by the system:

http://localhost:3004/user/welcome?user[id]=12&key=b69b31e8769c18cf94684ea12331cff49e9d5d52

I open it up locally (of course) with the message that I am logged on. I
am not sure what is wrong. Any help with this is much appreciated. Thank
you all in advance.

Sincerely,

Robert D.


#2

Robert D. wrote:

Hello again,

It appears that there is no code to handle the URL when it comes in -
i.e. there is no code to verify the user! If anyone has any code for
this I would appreciate it. Thanks ahead of time.

Sincerely,

Robert D.

Scanning the code I found this to be odd too, when I was implementing
this, but it’s actually fairly simple.

The “login_required” filter handles the verification. Apply
“login_required” to your welcome page in a before_filter and it will
work as expected.

Jeff


#3

Hello again,

It appears that there is no code to handle the URL when it comes in -
i.e. there is no code to verify the user! If anyone has any code for
this I would appreciate it. Thanks ahead of time.

Sincerely,

Robert D.


#4

Scanning the code I found this to be odd too, when I was implementing
this, but it’s actually fairly simple.

The “login_required” filter handles the verification. Apply
“login_required” to your welcome page in a before_filter and it will
work as expected.

Jeff

Jeff,

Thank you for your quick response. I added the before_filter
:login_required to the ApplicationController and all is well. I
appreciate the help.

Sincerely,

Robert D.