Sake error on Windows


#1

I have installed sake (gem install sake) on Windows machine. Now
whenever I
run sake on Windows, I get following error/message

Define INLINEDIR or HOME in your environment and try again

I googled about it and could not find that solved this problem.

Anybody have an idea how to solve this?


Don’t live to geek; geek to live.


#2

Set your home environment. You can do it at the commandline:

set HOME = c:\

That only works as long as that console window is open.

For a more permanent solution, you can do it via the environment
settings
(right click My Computer, choose Properties, choose “advanced” tab,
select
“Environment Variables” and create a new UJser variable. Make the name
HOME and the value c:\

You will not need to restart your computer but you will need to close
any
open console windows for those changes to take effect

That should help. (Not tested, but I know for a fact that the ZenTest
gem
makes you do the same thing on Windows.)


#3

yes, I did

set HOME = c:\

from command prompt in Windows. It still gives me the same error. :frowning:

Anil

On 7/16/07, Brian H. removed_email_address@domain.invalid wrote:

“Environment Variables” and create a new UJser variable. Make the name


Don’t live to geek; geek to live.
http://anilwadghule.com/blog


Don’t live to geek; geek to live.