S3 browser says my account is not valid

I created an amazon s3 account and I downloaded s3 browser for
windows here:
http://s3browser.com/

I put my keys in and tried to create a bucket, but it said my s3
account is not valid … Is it possible it is too new ?
Is there a better free browser ?

Thanks

I tried the ruby aws gem. If I can get a key and secret key from
amazon, I would assume my account is valid ? - unless it has not
refreshed through the system.
I get the error below.

I assume the "+’ and “/i” at the beggining and end of the secret key
are part of the key ?

If I can use this gem and get it to work, then maybe I don’t need an
s3 browser ?

C:\Users\Laurence\rails-play\test> gem i aws-s3

C:\Users\Laurence\rails-play\test>s3sh

AWS::S3::Base.establish_connection!(
?> :access_key_id => ‘Azzzzzzzzzzzzzzz’,
?> :secret_access_key => ‘+**************************/i’

)
=> #<AWS::S3::Connection:0x5953950 @http=#<Net::HTTP s3.amazonaws.com:
80 open=fa
lse>,
@options={:server=>“s3.amazonaws.com”, :access_key_id=>"***************
XQ", :secret_access_key=>"+/i", :port=>80},
@secret_access_key="+
***/i", @access_key_id="
AKIAJVY7TZDTM3SBLCXQ">

bucket = Bucket.create(‘free-spirit’)
AWS::S3::NotSignedUp: Your account is not signed up for the S3
service. You must
sign up before you can use S3.
from C:/Ruby187/lib/ruby/gems/1.8/gems/aws-s3-0.6.2/bin/…/lib/
aws/s3/er
ror.rb:38:in raise' from C:/Ruby187/lib/ruby/gems/1.8/gems/aws-s3-0.6.2/bin/../lib/ aws/s3/ba se.rb:72:inrequest’
from C:/Ruby187/lib/ruby/gems/1.8/gems/aws-s3-0.6.2/bin/…/lib/
aws/s3/ba
se.rb:88:in put' from C:/Ruby187/lib/ruby/gems/1.8/gems/aws-s3-0.6.2/bin/../lib/ aws/s3/bu cket.rb:79:increate’
from (irb):5
from :0

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs