S-l-o-w start up (maybe related to: Catching mouse clicks in fft_sink)


#1

It is probably unrelated to the mouse behavuour but I’m experiencing
very slow start up of my very simple app. The gadgets at the right
hand side of the fft panel for setting the units, etc. aren’t appearing
and neither are the menu and status bars. I have done a fresh build from
the 3.1.3 tarball (after purging the 2.6 wxpython files) and verified
against the audio_fft.py which also behaves the same (non-gui things
work fine). Any appropriate clues, hints or advice is welcome.

Stevie


#2

The code can be found here http://pastebin.com/m6d14a6aa.


#3

It is probably unrelated to the mouse behavuour but I’m experiencing
very slow start up of my very simple app. The gadgets at the right hand
side of the fft panel for setting the units, etc. aren’t appearing and
neither are the menu and status bars. I have done a fresh build from the
3.1.3 tarball (after purging the 2.6 wxpython files) and verified against
the audio_fft.py which also behaves the same (non-gui things work fine).
Any appropriate clues, hints or advice is welcome.

Sounds like your system could be sucking wind. Have you looked at “top”
to see what your top processes are in terms of CPU and memory usage
before starting your simple GNU Radio application? If something is
currently eating up your CPU, everything is going to lag. Given that
things don’t change on your build, I’m guessing it’s your system. Do
you run something like compiz-fusion/XGL/etc?

  • George