Ryby 1.9 encoding, mi sto stressando

Da quando uso la versione 1.9 tutte le applicazioni danno errore
quando incontrano caratteri accentati, eppure in application.rb ho
indicato come default encoding l’utf-8.
Si puo’ risolvere in qualche modo questo fastidio?

2011/12/21 Mauro [email protected]:

Da quando uso la versione 1.9 tutte le applicazioni danno errore
quando incontrano caratteri accentati, eppure in application.rb ho
indicato come default encoding l’utf-8.
Si puo’ risolvere in qualche modo questo fastidio?

dipende da dove sta l’errore.

  • i tuoi file .rb che encoding hanno?
  • Hai spiegato all’interprete che deve interpretarli come utf-8 (con
    il commento magico a inizio file)?
  • Il tuo database utf8?
  • La connessione al database?
  • La tabella?
  • La colonna?
  • che db usi?
  • che db adapter usi?

Rule of thumb: se tutto utf-8 funziona, se hai un singolo pezzo che
non lo fa prima funzionava perch non c’era un check ma ora ti scoppia
in faccia.


twitter: @riffraff
blog (en, it): www.riffraff.info riffraff.blogsome.com
work: cascaad.com circleme.com

2011/12/21 gabriele renzi [email protected]:

  • Il tuo database utf8?
  • La connessione al database?
  • La tabella?
  • La colonna?
  • che db usi?
  • che db adapter usi?

Rule of thumb: se tutto utf-8 funziona, se hai un singolo pezzo che
non lo fa prima funzionava perch non c’era un check ma ora ti scoppia
in faccia.

Sono le views che non funzionano se trovano dei caratteri accentati,
devo usare le codifiche html come ù
Lo stesso dicasi per i flash messages, se uso caratteri accentati mi
da errore, il resto e’ tutto ok.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs