Rx_voice and tx_voice

Hello,
I’m trying to run tx_voice and rx_voice, with FLEX900. I have two PCs
with
Ubuntu 7, and the version of GNU Radio is 3.1.2.
What I’m doing is:

For the receiver:

…/examples/digital# ./rx_voice.py -f 900M -O plughw:0,0
>>> gr_fir_fff: using SSE
gr_buffer::allocate_buffer: warning: tried to allocate
992 items of size 33. Due to alignment requirements
4096 were allocated. If this isn’t OK, consider padding
your structure to a power-of-two bytes.
On this platform, our allocation granularity is 4096 bytes.

For the transmitter:

…/examples/digital# ./tx_voice.py -f 900M
*>>> gr_fir_fff: using SSE
gr_buffer::allocate_buffer: warning: tried to allocate
992 items of size 33. Due to alignment requirements
4096 were allocated. If this isn’t OK, consider padding
your structure to a power-of-two bytes.
On this platform, our allocation granularity is 4096 bytes.
…(…)
*

And If I do in reverse, I mean, the other PC is now the transmitter, and
the
other the receiver, it happened this:
…/examples/digital# ./rx_voice.py -f 900M -O plughw:0,0
*>>> gr_fir_fff: using SSE
audio_alsa_sink[plughw:0,0]: set_period_time_near failed: Invalid
argument
Traceback (most recent call last):
File “./rx_voice.py”, line 139, in
main()
File “./rx_voice.py”, line 129, in main
tb = my_top_block(demods[options.modulation], rx_callback, options)
File “./rx_voice.py”, line 68, in init
self.audio_tx = audio_tx(options.audio_output)
File “./rx_voice.py”, line 56, in init
audio_sink = audio.sink(44100, audio_output_dev)
File “/usr/lib/python2.5/site-packages/gnuradio/audio_alsa.py”, line
236,
in sink
return _audio_alsa.sink(args)
RuntimeError: audio_alsa_sink

I don’t know what I’m doing wrong, or what is what I have to change.
Thanks

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs