Rx_voice and tx_voice help

Hello…
We trying to run rx_voice and tx_voice python codes. It worked for
the first time we could listen voice from the receiver side. But when
we stop the code and try it again but this time an error occured
about audio_alsa_sink and code didn’t run. We tried this a few times
and see that to run the code properly we should close the terminal
and open a new terminal and also shut down the usrp and open it
again.After these code could run again.What can be the reason of this
and what should we do?
I’m copying the error:

audio_alsa_sink[hw:0,0]: Device or resource busy
Traceback (most recent call last):
File “rx_voice.py”, line 133, in
main()
File “rx_voice.py”, line 123, in main
tb = my_top_block(demods[options.modulation], rx_callback, options)
File “rx_voice.py”, line 65, in init
self.audio_tx = audio_tx(options.audio_output)
File “rx_voice.py”, line 54, in init
audio_sink = audio.sink(8000, audio_output_dev)
File “/usr/lib/python2.6/dist-packages/gnuradio/audio_alsa.py”, line
299, in sink
return _audio_alsa.sink(*args, **kwargs)
RuntimeError: audio_alsa_sink

Best Regards..
Merve..

2010/4/11 [email protected]:

File “/usr/lib/python2.6/dist-packages/gnuradio/audio_alsa.py”, line
299, in sink
return _audio_alsa.sink(*args, **kwargs)
RuntimeError: audio_alsa_sink

Hi,

You can see which applications/daemons use the sound devices with

lsof /dev/snd/pcmC*

(pulseaudio should be okay)
I have seen this error many times when using flashplayer before
running a GNU Radio script, but I have never seen it on two executions
of the same GNU Radio script. Maybe you terminate your script
abnormally and the device is not closed?

Alex

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs