RVM use 1.8.7 doesn't work

For some reason on my Ubuntu VM - 10.04

when I install ruby 1.8.7 with rvm it seems to have a problem switching
to it. RVM functions perfectly when installing and using ruby 1.9.2 -
but this silent fail only seems to happen with ruby 1.8.7

BTW - all dependencies listed in RVM notes have been installed

see gist here: https://gist.github.com/1125409

Any ideas?

What does your PATH look like?

For BASH you’d type this into a terminal:

rvm use 1.8.7
echo $PATH

You seem to be using zsh which I’m not familiar with but I’d imagine
it’s something similar

And post the results. I’m guessing that your PATH doesn’t include
correct .rvm directory.

My path current PATH looks like this:
[email protected] ~$ rvm use 1.9.2
[email protected] ~$ echo $PATH
/Users/tim/.rvm/gems/ruby-1.9.2-p180/bin:/Users/tim/.rvm/gems/[email protected]/bin:/Users/tim/.rvm/rubies/ruby-1.9.2-p180/bin:/Users/tim/.rvm/bin:/opt/local/bin:/opt/local/sbin:/sbin:/bin:/usr/bin:/usr/sbin:/usr/local/bin

On 05/08/2011, at 1:18 AM, Anthony R. wrote:

Any ideas?


Posted via http://www.ruby-forum.com/.

Tim McGilchrist
[email protected]

On Thu, Aug 4, 2011 at 10:18 AM, Anthony R. [email protected] wrote:

Any ideas?


Posted via http://www.ruby-forum.com/.

After installing, you need to reload your environment. Just open a new
window. (If you don’t have the rvm stuff in your .bash_profile (or
equivalent) then you’ll need that. More can be seen on this at
https://rvm.beginrescueend.com/rvm/install