RVM install ruby problem, plz help

RVM install ruby problem, plz help

So, this command and this output:
[email protected]:~$ rvm install 1.9.2
Installing Ruby from source to: /home/misha/.rvm/rubies/ruby-1.9.2-p290,
this may take a while depending on your cpu(s)…

ruby-1.9.2-p290 - #fetching
ruby-1.9.2-p290 - #downloading ruby-1.9.2-p290, this may take a while
depending on your connection…
% Total % Received % Xferd Average Speed Time Time Time
Current
Dload Upload Total Spent Left
Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:--
0
curl: (7) couldn’t connect to host
ERROR: There was an error, please check
/home/misha/.rvm/log/ruby-1.9.2-p290/.log. Next we’ll try to fetch via
http.
Trying http:// URL instead.
% Total % Received % Xferd Average Speed Time Time Time
Current
Dload Upload Total Spent Left
Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:--
0
curl: (7) couldn’t connect to host
ERROR: There was an error, please check
/home/misha/.rvm/log/ruby-1.9.2-p290/
.log
ERROR: There has been an error while trying to fetch the source.
Halting the installation.
ERROR: There has been an error fetching the ruby interpreter. Halting
the installation.

Any hint?

Installed in single user.

Can you try using another internet connection?

Godspeed –
Junayeed Ahnaf N.
Twitter - @Nirjhor

You could download the ruby source manually and put it under where RVM
expects it.

Can you try using another internet connection?
Why? This internet connection works.

You could download the ruby source manually and put it under where RVM
expects it.
I think it’s wrong way. Will I installing every gem by this way? Will I
bundle install?

It looks like you may be required to use a proxy server to access the
Internet from your location. You probably have your regular web browser
already configured to do that, but curl won’t know about those settings.
So, my web browser don’t use proxy.

Misha

On 11/18/2011 12:46, Misha O. wrote:

% Total % Received % Xferd Average Speed Time Time Time
% Total % Received % Xferd Average Speed Time Time Time
ERROR: There has been an error fetching the ruby interpreter. Halting
the installation.

Any hint?

It looks like you may be required to use a proxy server to access the
Internet from your location. You probably have your regular web browser
already configured to do that, but curl won’t know about those settings.

Try setting the HTTP_PROXY environment variable to point to your proxy
server. Make sure you export that:

export HTTP_PROXY=http://some-server.example.com:1234/

Use your real server’s information, of course. The curl program should
use that to access the Internet through your proxy server and hopefully
resolve this issue for you.

-Jeremy

I solved the problem. I forgot that I create a proxy in GUI settings of
my ubuntu.

  1. Change internet connection to direct
  2. Logout -> Login

Misha

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs