Ruport error message

Hi

I was
getting the above error message when this lines of code were executed:

require “rubygems”
require “ruport”
require “ruport/util”

a = Ruport::Data::Record.new({:ruby_version =>
“1.8.5”},{:rubygems_version => “0.9.2”},{:hosts_os => “darwin8.8.2”})

Result:

C:/ruby/lib/ruby/gems/1.8/gems/ruport-util-0.12.0/lib/ruport/util/report.rb:47:
uninitialized constant Ruport::Report::Renderer (NameError)
from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from
C:/ruby/lib/ruby/gems/1.8/gems/ruport-util-0.12.0/lib/ruport/util.rb:13
from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in
gem_original_require' from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:inrequire’
from ./ruport.rb:3
from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from
F:/development/ruby_apps/file_reader/RubyApplication2/lib/foo.rb:2

Could someone please help me solve this ?

thanks

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs