RuntimeError: Unable to find USRP #0


#1

Hello guys,
I have already installed the gnuradio on Ubuntu 8.10 (interpid) and the
dial_tone.py is working fine. Then, I was trying to test the
usrp_wfm_rcv.py with my USRP which takes input from 10.7M scanner but I
came to the following error:

ubuntuvm@ubuntuvm:~/Desktop/gnuradio-3.1.3/gnuradio-examples/python/usrp$
./usrp_wfm_rcv.py -f 10.7M
Traceback (most recent call last):
 File “./usrp_wfm_rcv.py”, line 290, in
   app = stdgui2.stdapp (wfm_rx_block, “USRP WFM RX”)
 File
“/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py”, line
36, in init
   wx.App.init (self, redirect=False)
 File
“/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py”, line
7912, in init
   self._BootstrapApp()
 File
“/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py”, line
7487, in _BootstrapApp
   return core.PyApp__BootstrapApp(*args, **kwargs)
 File
“/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py”, line
39, in OnInit
   frame = stdframe (self.top_block_maker, self.title, self._nstatus)
 File
“/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py”, line
60, in init
   self.panel = stdpanel (self, self, top_block_maker)
 File
“/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py”, line
81, in init
   self.top_block = top_block_maker (frame, self, vbox, sys.argv)
 File “./usrp_wfm_rcv.py”, line 79, in init
   self.u = usrp.source_c()                   # usrp is data source
 File “/usr/local/lib/python2.5/site-packages/gnuradio/usrp.py”, line
247, in init
   _ensure_rev2(which)
 File “/usr/local/lib/python2.5/site-packages/gnuradio/usrp.py”, line
85, in _ensure_rev2
   v = _look_for_usrp(which)
 File “/usr/local/lib/python2.5/site-packages/gnuradio/usrp.py”, line
79, in _look_for_usrp
   raise RuntimeError, “Unable to find USRP #%d” % (which,)
RuntimeError: Unable to find USRP #0

Any help is appreciated!
Teka
  Â


#2

On Tue, Dec 23, 2008 at 3:53 PM, teka yemane removed_email_address@domain.invalid wrote:

app = stdgui2.stdapp (wfm_rx_block, "USRP WFM RX")

line 39, in OnInit
in init
Teka


Discuss-gnuradio mailing list
removed_email_address@domain.invalid
http://lists.gnu.org/mailman/listinfo/discuss-gnuradio

I have recently had this kind of problem, so maybe I can help.
Did you make sure udev is working correctly and you have read/write
permissions to the block device?


Igor A.


#3

teka yemane wrote:

Hello guys,
I have already installed the gnuradio on Ubuntu 8.10 (interpid) and the
dial_tone.py is working fine. Then, I was trying to test the
usrp_wfm_rcv.py with my USRP which takes input from 10.7M scanner but I
came to the following error:

   raise RuntimeError, “Unable to find USRP #%d” % (which,)
RuntimeError: Unable to find USRP #0

Any help is appreciated!
Teka
  Â

I usually face this error. and always it is when i didnot correctly plug
in the USB cable or the power cable to the USRP.

I don’t know whether it is same problem for you. So, ignore it if not.