Runtime error

Hello everybody.

I just upgrade my gem version 1.37 to 1.8.11. Then i run my project and
got
a this error.

START Error

Invalid gemspec in
[/usr/lib/ruby/gems/1.8/specifications/json-1.6.1.gemspec]: invalid date
format in specification: “2011-09-18 00:00:00.000000000Z”
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:55:
uninitialized constant ActiveSupport::Dependencies::Mutex (NameError)
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in
gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:inrequire’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support.rb:56
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in
gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:inrequire’
from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/commands/server.rb:1
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in
gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:inrequire’
from script/server:4


END Error

And my gem list is

rack (1.2.3, 1.0.1)
rack-mount (0.6.14)
rack-test (0.5.7)
rails (2.3.5)
railties (3.0.9)
rake (0.9.2)
rbx-require-relative (0.0.5)
rdoc (3.9.1)
rmagick (2.13.1)
ruby-debug (0.10.4)
ruby-debug-base (0.10.4)
rubygems-update (1.8.11, 1.4.0)
thor (0.14.6)
transaction-simple (1.4.0)
treetop (1.4.10)
ttfunk (1.0.3)
tzinfo (0.3.29)
will_paginate (2.3.15)

Psl help me [?]

Thanks
Tsolmon

On Oct 19, 12:01pm, Tsolmon N. [email protected] wrote:

/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependen
cies.rb:55:
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in
rack-mount (0.6.14)
thor (0.14.6)

330.gif
< 1KViewDownload

I don’t believe you listed your entire gem list - important things
like activerecord, actionmailer, etc. are missing. You should have a
json gem. Try updating it. (gem update json)

Sorry .

My gem list is.

abstract (1.0.0)
actionmailer (3.0.9, 2.3.5)
actionpack (3.0.9, 2.3.5)
activemodel (3.0.9)
activerecord (3.0.9, 2.3.5)
activeresource (3.0.9, 2.3.5)
activesupport (3.0.9, 2.3.5)
arel (2.0.10)
Ascii85 (1.0.1)
bcrypt-ruby (3.0.0)
builder (3.0.0, 2.1.2)
bundle (0.0.1)
bundler (1.0.15)
calendar_date_select (1.16.3)
cgi_multipart_eof_fix (2.5.0)
color (1.4.1)
columnize (0.3.4)
daemons (1.1.4)
erubis (2.6.6)
fastthread (1.0.7)
formtastic (1.2.4)
gem_plugin (0.2.3)
hoe (2.12.3)
i18n (0.4.2)
linecache (0.46)
mail (2.2.19)
mime-types (1.16)
mongrel (1.1.5)
multi_json (1.0.3)
mysql (2.8.1)
paperclip (2.3.5)
pdf-reader (0.10.0)
pdf-writer (1.1.8)
polyglot (0.3.2)
prawn (0.12.0)
rack (1.2.3, 1.0.1)
rack-mount (0.6.14)
rack-test (0.5.7)
rails (2.3.5)
railties (3.0.9)
rake (0.9.2)
rbx-require-relative (0.0.5)
rdoc (3.9.1)
rmagick (2.13.1)
ruby-debug (0.10.4)
ruby-debug-base (0.10.4)
rubygems-update (1.8.11, 1.4.0)
thor (0.14.6)
transaction-simple (1.4.0)
treetop (1.4.10)
ttfunk (1.0.3)
tzinfo (0.3.29)
will_paginate (2.3.15)

How to solve this problem.

Just upgrade to the latest edge Rails version to anything >= v2.3.10.
This
solves the problem. (There is a ‘threads’ dependency in the stack which
causes this error).

If you cannot upgrade your Rails version, you would need to downgrade
the
gem version.

Cheers!

  • Gautam

On Thu, Oct 20, 2011 at 2:47 PM, Tsolmon N.
[email protected]wrote:

activesupport (3.0.9, 2.3.5)
daemons (1.1.4)
multi_json (1.0.3)
railties (3.0.9)
ttfunk (1.0.3)

[/usr/lib/ruby/gems/1.8/specifications/json-1.6.1.gemspec]: invalid date
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support.rb:56

rake (0.9.2)
tzinfo (0.3.29)
I don’t believe you listed your entire gem list - important things
http://groups.google.com/group/rubyonrails-talk?hl=en.

All wiyht. Rho sritched mg kegtops awound?

Thanks all. This problem is solved.

Regards
Tsolmon

thats right its a gem versiion problem, downgrade it

Enviado via iPad

Em 20/10/2011, s 07:04, Gautam R. [email protected] escreveu:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs