Running rails on Linux

Hi guys,
I initially developed an application using Locomotive on Mac OS X. I
developed 2 applications which use one database. Now I would like to
export them to a Linux box. How do I go about doing that.
My applications use, Ruby-LDAP library and Net-SSH library.

On the Linux box, I have installed Ruby gems and installed Rails
successfully and also I ran the command ‘gem install net-ssh’ and
installed that successfully.
But this command ‘gem install ruby-ldap’ failed. Is there any reason it
failed?

Thanks!

Hi Jay

What error message did you get when you tried to gem install ruby-
ldap? The reason why it failed is probably in there somewhere.

David

I recommend installing Ubuntu Server 6.10 LTS and using Capistrano
along with the deprec gem http://www.deprec.org/ to install and
configure everything you need. Be sure to install deprec before
capistrano, so that it installs Capistrano 1.4.1 - not 2.0. This
installs and configures Apache, MySQL, Mongrel, Mongrel_Cluster, and
all other gems you need to set up a deployment server. If you don’t
have subversion set up already, there’s a recipe included for that,
too. Take a look at the free PeepCode mini-episode on how to create a
linux deployment box with deprec. It’s linked off this page: <https://
peepcode.com/products/capistrano-concepts> (The Capistrano screencast
is definitely worth the $9, btw.)

I just got through doing this myself this week, and I’m a Mac guy too.
It’s definitely easier than configuring a Mac server - even with
macports. (I tried that, first.) It will help if you have some
familiarity with Debian-based linux. If you’ve used macports, apt-
cache and apt-get will be easy to use to install anything else you
might need. (I had to install Curl, to test my mongrel cluster,
Postgres-8.2, and the ruby-postgres library.) The mini-episode is very
good, but it missed one key point - the configuration which allows
mongrel cluster to run on startup . Be sure to read this page, which
covers it : http://mongrel.rubyforge.org/docs/mongrel_cluster.html

Good luck!

On 8/17/07, redbaritone [email protected] wrote:

I recommend installing Ubuntu Server 6.10 LTS and using Capistrano
along with the deprec gem http://www.deprec.org/

There is also RubyWorks: http://rubyworks.thoughtworks.com
It doesn’t cover as much ground as deprec, but works on RHEL, CentOS and
Debian.


Alexey V.
CruiseControl.rb [http://cruisecontrolrb.thoughtworks.com]
RubyWorks [http://rubyworks.thoughtworks.com]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs