Running Rails App Via Passenger

Tried to access a Rails app on the local PC by entering in eaa via
Chrome
but ended up with a web search instead. How do I access the Rails app
locally? Below is the Apache config for the application:

*<VirtualHost *:80> *

  • ServerName eaa*
  • RailsEnv production*
  • DocumentRoot /var/rails-apps/eaa/public*
  • <Directory /var/rails-apps/eaa/public> *
  •    # Relax Apache security settings .*
    
  •    AllowOverride all*
    
  •    # MultiViews must be turned off .*
    
  •    Options -MultiViews*
    
  • *
  • ErrorLog ${APACHE_LOG_DIR}/error.log*

Had a look through the Apache error log and only found the following
info
message:

[Thu Feb 14 14:36:41 2013] [notice] Apache/2.2.22 (Ubuntu)
Phusion_Passenger/3.0.19 configured – resuming normal operations

Do you have eaa mapped to localhost in your /etc/hosts file?

Don’t have an entry for eaa in the hosts file. Tried accessing the
website
after adding the entry but ended up with the same result.

Managed to access the website by adding Listen 1025 to the Apache
config
file, and adding an entry to the hosts file. Have used a different port
for
the website (in its VirtualHost entry). Port 80 is already taken by the
default website.

Using a different IP address only works for a website if it is accessed
remotely, not locally (on the same PC).

Hmm… not sure then. This is a line out of my /etc/hosts file:

192.168.1.10 tamwiki.caesar.local tamwiki.caesar tamwiki

<VirtualHost *:80>
ServerName tamwiki.caesar.local
ServerAlias tamwiki
ServerAdmin [email protected]

DocumentRoot /var/www/vhosts/tamwiki
<Directory /var/www/vhosts/tamwiki>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from 192.168
allow from 127.0.0.1

With that, I can plug “http://tamwiki”, “http://tamwiki.caesar”, or
http://tamwiki.caesar.local” into the address bar and have it work.

On Thursday, February 14, 2013 5:31:38 PM UTC-5, Nick Apperley wrote:

Managed to access the website by adding Listen 1025 to the Apache
config file, and adding an entry to the hosts file. Have used a different
port for the website (in its VirtualHost entry). Port 80 is already taken
by the default website.

You can serve multiple sites from the same IP address and port if Apache
is
set up correctly. My virtual hosts file has this at the top:

Use name-based virtual hosting.

NameVirtualHost *:80

Also, I don’t think you want to have a single-component domain name.
For
example, if the site would eventually go live at eea.com, then you could
set up your dev site with servername of eea.local, so that once the site
is
live you can access both the live site and your local site without
having
to change your hosts file.

On Fri, Feb 15, 2013 at 6:41 AM, Jim [email protected] wrote:

You can serve multiple sites from the same IP address and port if Apache is
set up correctly.

Or you can eliminate a whole lot of configuration nonsense by using
Pow (http://pow.cx/) for development :slight_smile: and simply access your app
locally as e.g. http://eaa.dev/

FWIW,

Hassan S. ------------------------ [email protected]
http://about.me/hassanschroeder
twitter: @hassan

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs