Running... libwx_gtk2u_gl-2.8.so.0

Hi all, i´m new at wxruby on Linux so when i run my first program:

require ‘rubygems’
require ‘wx’
include Wx

class MyFrame < Frame
def initialize()
super(nil, -1, ‘Hi’)
end
end


$ ruby oi.rb
/usr/lib/ruby/gems/1.8/gems/wxruby-1.9.9-x86-linux/lib/wxruby2.so:
libwx_gtk2u_gl-2.8.so.0: cannot open shared object file: No such file or
directory -
/usr/lib/ruby/gems/1.8/gems/wxruby-1.9.9-x86-linux/lib/wxruby2.so
(LoadError)
from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in require' from /usr/lib/ruby/gems/1.8/gems/wxruby-1.9.9-x86-linux/lib/wx.rb:12 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:ingem_original_require’
from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require’
from oi.rb:2

How to fix it ?
thanks any help

Hi,

2010/2/26 Gugão [email protected]:

  from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in

gem_original_require' from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:inrequire’
from oi.rb:2

How to fix it ?

The wxWidgets library is probably not installed on your system.
On Ubuntu, try :
sudo apt-get install libwxgtk2.8-0

It seems also that you’re using an old wxRuby package (1.9.9).
You should use the latest stable release (2.0.1).

Cheers.
Chauk-Mean

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs