Running JRuby on Jetty I get directory listing

I have created a Rails application using Netbeans RC2, with the built-in
JRuby 1.0.2. Everythign works fine in webrick. I create de .war file and
it’s created right. But when I execute the war:standalone:run rake task
and go to http://localhost:8080/myapp I see a directory listing instead
of the Ruby application. I also tried to drop the .war file into
Glassfish and into Tomcat but I alwais see the diectory listing.

Have you got any idea of the cause? Has anybody ever had this problem?

Thanks

I am having this problem also.

Gordon Duquesnay wrote:

I am having this problem also.

Hi Gordon

I finally solved the problem. The problem is that Netbeans is not
creating the web.xml in the WEB-INF directory. I created it manually and
everything worked right. You can use the
/vendor/plugins/goldspike/generators/goldspike/templates/web.xml.erb
file as the template

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs