Running debug with tk causes error

If I run a simple tk script without debug, it works fine, but when I run
with debug I can’t get past the autoload.rb. It doesn’t seem to matter
tk program I try to debug.

I am on the latest update of the Raspberry Pi (raspbian)
I am running ruby 1.9.3p194 (2012-04-20 revision 35410)
I am running Tk::TK_PATCHLEVEL => “8.5.11”

Here is my debug session:

ruby -rdebug tk2.rb
Emacs support available.

tk2.rb:3:require ‘tk’

(rdb:1) c

/usr/lib/ruby/1.9.1/tk/autoload.rb:418: `’ (NilClass)

from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require’

from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require’

from /usr/lib/ruby/1.9.1/tk.rb:10:in `<top (required)>’

from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require’

from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require’

from tk2.rb:3:in `’

sym} rescue nil # ignore err

(rdb:1) q

Really quit? (y/n) y
I have googled various ways with no success?
I am also fairly new to ruby.

Is this a bug, or is it known, and if so, is there a work-a-round?


Extra Ham Operator: K7AZJ
Registered Linux User: 275424
Raspberry Pi and Arduino developer

The most exciting phrase to hear in science - the one that heralds new
discoveries - is not “Eureka!” but “That’s funny…”.
- Isaac. Asimov

*f you give someone a program, you will frustrate them for a day; if you
teach them how to program, you will frustrate them for a lifetime. *-

If writing good code requires very little comments, then writing really
excellent code requires no comments at all!
- Ken Thompson