Rubygems won't run on WinXP after system update

hello.

Anyone tried to upgrade rubygems from windows xp?

I downloaded fresh ruby 1.8.6 installer, installed, did gem update
–system and now whenever I try anything, i get this:

C:\Documents and Settings\Artūras>gem update --system
Updating RubyGems
ERROR: While executing gem … (Errno::ENOENT)
No such file or directory - C:\Documents and Settings\Artūras

Tried googling, nothing there…

Tried changing USERPROFILE env var to c:\ and c://, but still no luck :expressionless:

Any ideas?

On Jul 6, 10:26 pm, Artûras Ðlajus [email protected] wrote:

No such file or directory - C:\Documents and Settings\Artûras

Tried googling, nothing there…

Tried changing USERPROFILE env var to c:\ and c://, but still no luck :expressionless:

Any ideas?

Dunno your previous setup configuration, but your username contains an
extended accented character which will make the life of any non-
unicode application hard.

To workaround this I suggest you set HOME environment variable to
something different than Documents and Settings, since will have the
same problem.

Also, do not mess with USERPROFILE since ti serve other purpose beside
being used by applications, USERPROFILE is the place Windows stored
the ntuser part of registry, which I suggest you stay away from it :slight_smile:

HTH,

C:\Documents and Settings\Artûras>gem update --system

You could try to add the --debug flag for additional output.

ThoML wrote:

You could try to add the --debug flag for additional output.

C:\Documents and Settings\Artūras>gem update --system --debug
Exception NameError' at c:/ruby/lib/ruby/site_ruby/1.8/rubygems/command_manager .rb:134 - uninitialized constant Gem::Commands::UpdateCommand Updating RubyGems ExceptionErrno::ENOENT’ at
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/spec_fetche
r.rb:41 - No such file or directory - C:\Documents and Settings\Artūras
ERROR: While executing gem … (Errno::ENOENT)
No such file or directory - C:\Documents and Settings\Artūras
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:41:in
stat' c:/ruby/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:41:ininitializ
e’
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:32:in
new' c:/ruby/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:32:infetcher’
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/commands/update_command.rb:139:i
n which_to_update' c:/ruby/lib/ruby/site_ruby/1.8/rubygems/commands/update_command.rb:132:i neach’
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/commands/update_command.rb:132:i
n which_to_update' c:/ruby/lib/ruby/site_ruby/1.8/rubygems/commands/update_command.rb:68:inexecute’
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/command.rb:136:in
invoke' c:/ruby/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:105:inproce
ss_args’
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:75:in
run' c:/ruby/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:39:inrun’
c:/ruby/bin/gem:24

Luis L. wrote:

To workaround this I suggest you set HOME environment variable to
something different than Documents and Settings, since will have the
same problem.
Thanks, it seems to work :slight_smile:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs