Rubygems win32 error with ruby 1.8.4 (final)


#1

hi all. i’m using the ruby 1.8.4 binary from garbagecollect with dll’s
mentioned in the ‘how to install’ section. all seems fine except
rubygems reports this error when i try to install anything -

"Could not find RubyGem sources (0.0.0) (Gem::LoadError).

according to the gems website this was a problem with an earlier
version, but i’m using 0.8.11

thanks for any ideas


#2

or does someone have a link to the preview3 of ruby 1.8.4? i’m pretty
sure that worked ok.


#3

well, it was a blasted dll issue. i love windows! long live microsuck


#4

you may just need to set a few environmental variables to
indicate to ruby and gem where to look for your files.
the following is an example for somebody using a bash shell.
your paths and shell may differ – adjust accordingly.

export RUBYLIB=/lib/ruby/site_ruby/1.8:/lib/ruby/1.8
export GEM_PATH=/lib/ruby/gems/1.8
export GEM_HOME=/lib/ruby/gems/1.8


#5

On Wed, 2005-12-28 at 19:27 +0900, simonh wrote:

or does someone have a link to the preview3 of ruby 1.8.4? i’m pretty
sure that worked ok.

FWIW, lots of past Ruby versions are mirrored here:

http://rubyforge.org/frs/?group_id=426

Yours,

Tom