Rubygems-update 1.8.5 Released

rubygems-update version 1.8.5 has been released!

RubyGems is a package management framework for Ruby.

This gem is an update for the RubyGems software. You must have an
installation of RubyGems before this update can be applied.

See Gem for information on RubyGems (or ri Gem)

To upgrade to the latest RubyGems, run:

$ gem update --system # you might need to be an administrator or root

See UPGRADING.rdoc for more details and alternative instructions.


If you don’t have RubyGems installed, your can still do it manually:

For more details and other options, see:

ruby setup.rb --help

Changes:

1.8.5 / 2011-05-31

  • 2 minor enhancement:

  • The -u option to ‘update local source cache’ is official deprecated.

  • Remove has_rdoc deprecations from Specification.

  • 2 bug fixes:

  • Handle bad specs more gracefully.

  • Reset any Gem paths changed in the installer.

On Jun 4, 5:47pm, Le Couey [email protected] wrote:

HOMEPATH=\Documents and Settings\Lawrence
No such file or directory - C:/%HOMEPATH%
The problem is not HOMEPATH, or \ or / in the variable.

Please do “gem env” and provide that information.

Ruby uses a combination of HOMEDRIVE and HOMEPATH variables when
“HOME” variable is not defined, and then it will fall back to
USERPROFILE

So, please provide details about HOME, HOMEDRIVE and HOMEPATH values,
also ensure the variables ARE assigned or try doing this:

SET HOME=%HOMEDRIVE%%HOMEPATH%

And see what this produces:

ruby -ve “puts File.expand_path(’~’)”

On 5/31/2011 4:44 PM, Evan P. wrote:

This gem is an update for the RubyGems software. You must have an

  • Reset any Gem paths changed in the installer.

Evan,

I’ve run into a bit of a problem with this version of the
rubygems-update, (or
maybe it was the last one). It errors out when I try to update:

— 8< -------------------------- 8< --------------------------- 8<

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Lawrence>set homepath
HOMEPATH=\Documents and Settings\Lawrence

C:\Documents and Settings\Lawrence>set HOMEPATH=/Documents and
Settings/Lawrence

C:\Documents and Settings\Lawrence>set homepath
HOMEPATH=/Documents and Settings/Lawrence

— 8< -------------------------- 8< --------------------------- 8<

C:\Documents and Settings\Lawrence>gem update --system --backtrace
ERROR: While executing gem … (Errno::ENOENT)
No such file or directory - C:/%HOMEPATH%
C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:54:in
stat' C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:54:ininitialize’
C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:43:in
new' C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:43:infetcher’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/commands/update_command.rb:209:in
`block in which_to_update’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/commands/update_command.rb:203:in
`each’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/commands/update_command.rb:203:in
`which_to_update’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/commands/update_command.rb:158:in
`update_rubygems’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/commands/update_command.rb:61:in
execute' C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/command.rb:278:ininvoke’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/command_manager.rb:147:in
`process_args’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/command_manager.rb:117:in
run' C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/gem_runner.rb:65:inrun’
C:/lan/Ruby192/bin/gem:21:in `’

— 8< -------------------------- 8< --------------------------- 8<

C:\Documents and Settings\Lawrence>echo C:/%HOMEPATH%
C://Documents and Settings/Lawrence

C:\Documents and Settings\Lawrence>set HOMEPATH=Documents and
Settings/Lawrence

C:\Documents and Settings\Lawrence>echo C:/%HOMEPATH%
C:/Documents and Settings/Lawrence

— 8< -------------------------- 8< --------------------------- 8<

C:\Documents and Settings\Lawrence>gem update --system --backtrace
ERROR: While executing gem … (Errno::ENOENT)
No such file or directory - C:/%HOMEPATH%
C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:54:in
stat' C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:54:ininitialize’
C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:43:in
new' C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:43:infetcher’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/commands/update_command.rb:209:in
`block in which_to_update’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/commands/update_command.rb:203:in
`each’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/commands/update_command.rb:203:in
`which_to_update’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/commands/update_command.rb:158:in
`update_rubygems’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/commands/update_command.rb:61:in
execute' C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/command.rb:278:ininvoke’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/command_manager.rb:147:in
`process_args’

C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/command_manager.rb:117:in
run' C:/lan/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/gem_runner.rb:65:inrun’
C:/lan/Ruby192/bin/gem:21:in `’

— 8< -------------------------- 8< --------------------------- 8<

C:\Documents and Settings\Lawrence>cd \

C:>cd c:/%HOMEPATH%

C:\Documents and Settings\Lawrence>time
The current time is: 15:24:15.81
Enter the new time:

C:\Documents and Settings\Lawrence>date
The current date is: Sat 06/04/2011
Enter the new date: (mm-dd-yy)

C:\Documents and Settings\Lawrence>
— 8< -------------------------- 8< --------------------------- 8<

As you can see I’m currently running on my:
o Windows XP Pro, SP3, system
o ruby 1.9.2p0 (2010-08-18) [i386-mingw32]
o gem 1.8.4
o 8 GB RAM (only <4 GB usable in XP)

My install of rubygems-update 1.8.4 was no problem:

— 8< -------------------------- 8< --------------------------- 8<

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:>gem update --system
Fetching: rubygems-update-1.8.4.gem (100%)
Temporarily enhancing PATH to include DevKit…
Successfully installed rubygems-update-1.8.4
Installing RubyGems 1.8.4
RubyGems 1.8.4 installed
unable to convert U+0160 from UTF-8 to IBM437 for History.txt, skipping
unable to convert U+0160 from UTF-8 to IBM437 for History.txt, skipping

n++=== 1.8.4 / 2011-05-25

  • 1 minor enhancement:

    • Removed default_executable deprecations from Specification.

RubyGems installed the following executables:
C:/lan/Ruby192/bin/gem

RubyGems system software updated

C:>
— 8< -------------------------- 8< --------------------------- 8<

— 8< -------------------------- 8< --------------------------- 8<

So what have I done wrong this time?

Thank you for any and All Help!

Lawrence
- - - Professional nooby & Gomgoru

On 6/4/2011 4:40 PM, Luis L. wrote:

SET HOME=%HOMEDRIVE%%HOMEPATH%

And see what this produces:

ruby -ve “puts File.expand_path(’~’)”


Luis L.

Luis,

Thanks!

Everything appears to have worked (see following):

C:\Documents and Settings\Lawrence>gem env
RubyGems Environment:

  • RUBYGEMS VERSION: 1.8.4
  • RUBY VERSION: 1.9.2 (2010-08-18 patchlevel 0) [i386-mingw32]
  • INSTALLATION DIRECTORY: C:/lan/Ruby192/lib/ruby/gems/1.9.1
  • RUBY EXECUTABLE: C:/lan/Ruby192/bin/ruby.exe
  • EXECUTABLE DIRECTORY: C:/lan/Ruby192/bin
  • RUBYGEMS PLATFORMS:
    • ruby
    • x86-mingw32
  • GEM PATHS:
    • C:/lan/Ruby192/lib/ruby/gems/1.9.1
  • GEM CONFIGURATION:
    • :update_sources => true
    • :verbose => true
    • :benchmark => false
    • :backtrace => false
    • :bulk_threshold => 1000
  • REMOTE SOURCES:

— 8< -------------------------- 8< --------------------------- 8<

C:\Documents and Settings\Lawrence>set home
HOME=C:%HOMEPATH%
HOMEDRIVE=C:
HOMEPATH=\Documents and Settings\Lawrence

C:\Documents and Settings\Lawrence>echo ‘%HOME%’
‘C:%HOMEPATH%’

C:\Documents and Settings\Lawrence>set USERPROFILE
USERPROFILE=C:\Documents and Settings\Lawrence

C:\Documents and Settings\Lawrence>ruby -ve “puts File.expand_path(’~’)”
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]
C:/%HOMEPATH%

— 8< -------------------------- 8< --------------------------- 8<

C:\Documents and Settings\Lawrence>set HOME=%HOMEDRIVE%%HOMEPATH%

C:\Documents and Settings\Lawrence>SET HOME
HOME=C:\Documents and Settings\Lawrence
HOMEDRIVE=C:
HOMEPATH=\Documents and Settings\Lawrence

C:\Documents and Settings\Lawrence>ruby -ve “puts File.expand_path(’~’)”
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]
C:/Documents and Settings/Lawrence

C:\Documents and Settings\Lawrence>
— 8< -------------------------- 8< --------------------------- 8<

C:\Documents and Settings\Lawrence>gem update --system
Updating rubygems-update
Fetching: rubygems-update-1.8.5.gem (100%)
Temporarily enhancing PATH to include DevKit…
Successfully installed rubygems-update-1.8.5
Installing RubyGems 1.8.5
RubyGems 1.8.5 installed
unable to convert U+0160 from UTF-8 to IBM437 for History.txt, skipping
unable to convert U+0160 from UTF-8 to IBM437 for History.txt, skipping

n++=== 1.8.5 / 2011-05-31

  • 2 minor enhancement:

    • The -u option to ‘update local source cache’ is official deprecated.
    • Remove has_rdoc deprecations from Specification.
  • 2 bug fixes:

    • Handle bad specs more gracefully.
    • Reset any Gem paths changed in the installer.

RubyGems installed the following executables:
C:/lan/Ruby192/bin/gem

RubyGems system software updated

C:\Documents and Settings\Lawrence>time
The current time is: 17:15:20.62
Enter the new time:

C:\Documents and Settings\Lawrence>date
The current date is: Sat 06/04/2011
Enter the new date: (mm-dd-yy)

C:\Documents and Settings\Lawrence>

— 8< -------------------------- 8< --------------------------- 8<

On 6/4/2011 7:56 PM, Luis L. wrote:

The ^ around % will delay evaluation of the variable.

For the setting changes to work, you need to open a new terminal.


Luis L.

Luis,

Thanks for the help. I’ve got it working now. I went into System and
changed my personal environment variable for HOME. Now gem install works
as needed!

Again Thank you!
Lawrence

To upgrade to the latest RubyGems, run:

$ gem update --system # you might need to be an administrator or root

D:\installs\jruby-1.6.1\bin\jruby -S gem update --system
Updating RubyGems
ERROR: While executing gem … (NoMethodError)
undefined method `version’ for nil:NilClass

Cheers!
-roger-

On Jun 4, 7:57pm, Le Couey [email protected] wrote:

  • RUBY VERSION: 1.9.2 (2010-08-18 patchlevel 0) [i386-mingw32]
  • :verbose => true
    HOMEDRIVE=C:
    C:\Documents and Settings\Lawrence>SET HOME
    HOME=C:\Documents and Settings\Lawrence
    HOMEDRIVE=C:
    HOMEPATH=\Documents and Settings\Lawrence

C:\Documents and Settings\Lawrence>ruby -ve “puts File.expand_path(’~’)”
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]
C:/Documents and Settings/Lawrence

The problem is here, seems HOME is not properly evaluated… perhaps
%HOMEPATH% was escaped from evaluation.

You need to setup HOME properly, which I recommend you use SETX:

http://ss64.com/nt/setx.html

SETX HOME ^%HOMEDRIVE^%^%HOMEPATH^%

The ^ around % will delay evaluation of the variable.

For the setting changes to work, you need to open a new terminal.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs