Rubygems-update 1.8.2 Released

rubygems-update version 1.8.2 has been released!

RubyGems is a package management framework for Ruby.

This gem is an update for the RubyGems software. You must have an
installation of RubyGems before this update can be applied.

See Gem for information on RubyGems (or ri Gem)

To upgrade to the latest RubyGems, run:

$ gem update --system # you might need to be an administrator or root

See UPGRADING.rdoc for more details and alternative instructions.


If you don’t have RubyGems installed, your can still do it manually:

For more details and other options, see:

ruby setup.rb --help

Changes:

=== 1.8.2 / 2011-05-11

After installing RubyGems 1.8 or newer you will see deprecations when
loading
your exsting gems. Run gem pristine --all --no-extensions to
regenerate your
gem specifications safely.

Currently RubyGems does not save the build arguments used to build gems
with
extensions. You will need to run gem pristine gem_with_extension -- --build-arg to regenerate a gem with an extension where it requires
special
build arguments.

  • 2 minor enhancements:

    • Moved #outdated from OutdatedCommand to Specification (for Isolate).
    • Print out a warning about missing executables.
  • 3 bug fixes:

    • Added missing requires to fix various upgrade issues.
    • gem pristine respects multiple gem repositories.
    • setup.rb now execs with --disable-gems when possible

As an interesting note,
with this rails project:

https://github.com/rdp/musicformormons

with rubygems 1.3.7

config.gem and friends work well (if it’s vendored, it accepts that, if
it’s installed, it accepts that.

However, with rubygems 1.8.2, no amount of running

$ rake gems:install

prevents it from displaying the following error message:

Missing these required gems:
rack = 1.1.0
RedCloth

https://gist.github.com/969791

Cheers!
-r

On May 12, 2011, at 18:22 , Roger P. wrote:

However, with rubygems 1.8.2, no amount of running

$ rake gems:install

prevents it from displaying the following error message:

Missing these required gems:
rack = 1.1.0
RedCloth

Unfortunately, that’s a rails gem-hack issue… (I suspect).

Fortunately, I’m addressing at least a bit of it with my latest pull
request on rails. I’m hoping we can get a release out to address the
worst of it… but the hacks are piled on and I doubt that I’ll fix it
all.

On May 15, 2011, at 23:13 , Roger P. wrote:

rubygems-update version 1.8.2 has been released!

I’ve noticed that the “gem which” command seems to have changed.

$ gem which ruby-prof
/Library/Ruby/Gems/1.8/gems/ruby-prof-0.10.7/lib/ruby-prof

(it lists a directory now, instead of a file).

3006 % gem unpack ruby-prof
Fetching: ruby-prof-0.4.0.gem (100%)
Unpacked gem: ‘/Users/ryan/ruby-prof-0.4.0’
3007 % l ruby-prof-0.4.0/lib/
total 16
0 ruby-prof/ 8 ruby-prof.rb 8 unprof.rb

that also matches the ruby-prof.rb file given the rules of require.

rubygems-update version 1.8.2 has been released!

I’ve noticed that the “gem which” command seems to have changed.

$ gem which ruby-prof
/Library/Ruby/Gems/1.8/gems/ruby-prof-0.10.7/lib/ruby-prof

(it lists a directory now, instead of a file).
Expected?
Cheers!
-r

0 ruby-prof/ 8 ruby-prof.rb 8 unprof.rb

that also matches the ruby-prof.rb file given the rules of require.

Ok that makes sense, though causes a bit of confusion.
Cheers!
-r

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs