Rubygems-update 1.8.1 Released

rubygems-update version 1.8.1 has been released!

RubyGems is a package management framework for Ruby.

This gem is an update for the RubyGems software. You must have an
installation of RubyGems before this update can be applied.

See Gem for information on RubyGems (or ri Gem)

To upgrade to the latest RubyGems, run:

$ gem update --system # you might need to be an administrator or root

See UPGRADING.rdoc for more details and alternative instructions.


If you don’t have RubyGems installed, your can still do it manually:

For more details and other options, see:

ruby setup.rb --help

=== 1.8.1 / 2011-05-05

After installing RubyGems 1.8.1 you will see deprecations when loading
your
exsting gems. Run gem pristine --all --no-extensions to regenerate
your
gem specifications safely.

Currently RubyGems does not save the build arguments used to build gems
with
extensions. You will need to run gem pristine gem_with_extension -- --build-arg to regenerate a gem with an extension where it requires
special
build arguments.

  • 1 minor enhancement:

  • Added Gem::Requirement#specific? and Gem::Dependency#specific?

  • 4 bug fixes:

  • Typo on Indexer rendered it useless on Windows

  • gem dep can fetch remote dependencies for non-latest gems again.

  • gem uninstall with multiple versions no longer crashes with
    ArgumentError

  • Always use binary mode for File.open to keep Windows happy

Somehow, when running this 1.8.1 update, it broke three websites I have
in development. These are Apache sites which previously had passenger
configured to run in httpd.conf as follows:

LoadModule passenger_module
/usr/local/lib/ruby/gems/1.9.1/gems/passenger-3.0.7/ext/apache2/mod_passenger.so
PassengerRoot /usr/local/lib/ruby/gems/1.9.1/gems/passenger-3.0.7
PassengerRuby /usr/local/bin/ruby
<VirtualHost *:80>
ServerName flybobdev.ca.boeing.com
DocumentRoot /home/flybob/Rails/test_app/public

This was after I ran…

gem update --system
gem pristine --all --no-extensions

My /usr/local/lib/ruby/gems/1.9.1/gems/passenger-3.0.7/ext/apache2

No longer has any *.so files in it. Therefore Apache gives the
following error upon restart.

/etc/init.d/apache2 graceful

httpd: Syntax error on line 481 of /opt/apache_2.2.15/conf/httpd.conf:
Cannot load
/usr/local/lib/ruby/gems/1.9.1/gems/passenger-3.0.7/ext/apache2/mod_passenger.so
into server:
/usr/local/lib/ruby/gems/1.9.1/gems/passenger-3.0.7/ext/apache2/mod_passenger.so:
cannot open shared object file: No such file or directory

/usr/local/lib/ruby/gems/1.9.1/gems/passenger-3.0.7/ext/apache2
CONTAINS…

-rw-r–r-- 1 root root 5909 May 6 16:57 Bucket.cpp
-rw-r–r-- 1 root root 3345 May 6 16:57 Bucket.h
-rw-r–r-- 1 root root 30041 May 6 16:57 Configuration.cpp
-rw-r–r-- 1 root root 1881 May 6 16:57 Configuration.h
-rw-r–r-- 1 root root 12609 May 6 16:57 Configuration.hpp
-rw-r–r-- 1 root root 7801 May 6 16:57 DirectoryMapper.h
-rw-r–r-- 1 root root 11669 May 6 16:57 HelperAgent.cpp
-rw-r–r-- 1 root root 61223 May 6 16:57 Hooks.cpp
-rw-r–r-- 1 root root 1540 May 6 16:57 Hooks.h
-rw-r–r-- 1 root root 1995 May 6 16:57 mod_passenger.c

I also ran gem install passenger to migrate from 3.0.4 to 3.0.7

Does this make sense? Did the gem update break passenger or did
passenger change something that requires some sort of compile to get
the *.so file?

On Sat, May 7, 2011 at 5:14 AM, Eric H. [email protected] wrote:

After installing RubyGems 1.8.1 you will see deprecations when loading your
exsting gems. Run gem pristine --all --no-extensions to regenerate your
gem specifications safely.

it still is noisy. i had to (force) set Deprecate.skip to return true…

best regards -botp

On 05/06/2011 05:47 PM, botp wrote:

On Sat, May 7, 2011 at 5:14 AM, Eric H.[email protected] wrote:

After installing RubyGems 1.8.1 you will see deprecations when loading your
exsting gems. Run gem pristine --all --no-extensions to regenerate your
gem specifications safely.

it still is noisy. i had to (force) set Deprecate.skip to return true…

best regards -botp

I ended up doing gem pristine --all. A nice long coffee break :wink:

Steve D. wrote in post #997150:

Somehow, when running this 1.8.1 update, it broke three websites I have
in development. […]

My /usr/local/lib/ruby/gems/1.9.1/gems/passenger-3.0.7/ext/apache2

No longer has any *.so files in it. Therefore Apache gives the
following error upon restart. […]

Doesn’t Passenger have an extra step involved to build the
mod_.so? You would likely have to re-run that as well.

On Fri, May 6, 2011 at 4:14 PM, Eric H. [email protected] wrote:

This gem is an update for the RubyGems software. You must have an

special

  • gem uninstall with multiple versions no longer crashes with
    ArgumentError
  • Always use binary mode for File.open to keep Windows happy

After Rake and Bundler come on board, I’ll join you guys. But in the
meantime, I’m going to
$ gem update --system 1.7

Also, I have a gem, but wasn’t notified about this (maybe because mine
had
no issues?), if I wasn’t on the ML or following certain people on
Twitter or
didn’t update my Rubygems, I might not even know there could be
problems.
Maybe a mass email “check your gems are still valid” to gem authors? I’d
be
willing to opt into it on rubygems.org

To upgrade to the latest RubyGems, run:

$ gem update --system # you might need to be an administrator or root

I’m completely new to this stuff. When should “gem update” alone ever
be
run? Or does doing so break things?


Patrick Johnson

On Sun, May 8, 2011 at 4:52 AM, Patrick Johnson
[email protected] wrote:

I’m completely new to this stuff. When should “gem update” alone ever be
run? Or does doing so break things?

“gem update [gem]” updates a gem. If no argument is given, it updates
all gems.

What, if anything, breaks depends on the gems you have installed.


Phillip G.

Though the folk I have met,
(Ah, how soon!) they forget
When I’ve moved on to some other place,
There may be one or two,
When I’ve played and passed through,
Who’ll remember my song or my face.

On May 7, 2011, at 19:52 , Patrick Johnson wrote:

To upgrade to the latest RubyGems, run:

$ gem update --system # you might need to be an administrator or root

I’m completely new to this stuff. When should “gem update” alone ever be
run? Or does doing so break things?

The built-in help should explain things:

gem update --help

If not, let me know what I can help clarify.

On May 6, 2011, at 17:15 , Dame, Stephen G wrote:

This was after I ran…

gem update --system
gem pristine --all --no-extensions

My /usr/local/lib/ruby/gems/1.9.1/gems/passenger-3.0.7/ext/apache2

No longer has any *.so files in it. Therefore Apache gives the following error
upon restart.

http://www.modrails.com/install.html

Ah! Much thanks Ryan. This was the exact pointer needed. I had to run

passenger-install-apache2-module

to get the recompile.

However, now passenger is complaining about all kinds of things related
to “Ruby (Rack) application could not be started”

At first I thought it was bundle, but then I installed bundle. gem
install bundle

Then it seemed to be “Rack” so I gem install rack.

Now, I’m going down the bunny trail with an error message…

Ruby (Rack) application could not be started
Error message:
undefined method `matching_specs’ for
#Gem::Dependency:0x0000002049e588

Does anyone, familiar with installing Rails3 and Passenger, have an idea
on what the source of this error is?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs