In my rails app, i use several awesome gems. Gem X depends on 0.4
version of rubyforge, while Gem Y, depends on 1.0 version of rubyforge
gem. They all come with that value hardcoded in gemspecs. Now, this
creates loads of troubles. I have managed to fix this somehow till now
fortunately, because in my case, if gem X had hardcoded version of
rubyforge, gem Y didn’t had hardcoded dependency.
How to solve this?
Locking your program to a particular gem version is a good idea, but
its such a bad idea for distributable libraries.
Totally mysterious error messages, heck i run command buildr and get:
activate': can't activate rubyforge (~> 0.4, runtime), already activated rubyforge-1.0.0 (Gem::Exception) from /usr/local/lib/site_ruby/1.8/rubygems.rb:158:in activate’
each' from /usr/local/lib/site_ruby/1.8/rubygems.rb:157:in activate’
from /usr/local/lib/site_ruby/1.8/rubygems.rb:49:in `gem’
Let them talk of their oriental summer climes of everlasting
conservatories; give me the privilege of making my own summer with my