Rubygems-sing 1.2.0 Released

rubygems-sing version 1.2.0 has been released!

“Sings” a gem’s implementation.

Changes:

1.2.0 / 2010-01-27

  • 3 minor enhancements:

    • Added --verbose, to print more like a player piano (blank lines in
      between).
    • Added -r to sing gems you REALLY don’t want to install (rails, sans
      deps).
    • Added musical notes to output. (topFUNkay! OW!)

On Thu, Jan 28, 2010 at 8:42 AM, Ryan D. [email protected]
wrote:

  • 3 minor enhancements:

  • Added --verbose, to print more like a player piano (blank lines in between).

  • Added -r to sing gems you REALLY don’t want to install (rails, sans deps).

  • Added musical notes to output. (topFUNkay! OW!)

Hi Ryan,

I’ve tried to sing some gems in Ubuntu 8.10, but I keep getting an
error:

~$ gem sing rails
ERROR: While executing gem … (NameError)
uninitialized constant Gem::LocalRemoteOptions

I updated rubygems (gem update --system) and now the versions are:

[email protected]:~$ gem -v
1.3.5
[email protected]:~$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]

I googled around but couldn’t find anything related to this error. Any
idea?

Thanks,

Jesus.

On Jan 28, 2010, at 23:35 , Jesús Gabriel y Galán wrote:

[email protected]:~$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]

I googled around but couldn’t find anything related to this error. Any idea?

Huh. I’m developing against 1.3.5 as well… if I had to guess, I’d say
that ubuntu changed yet another thing in rubygems and that affects
sing… Dunno. Eric? Any clue?

On Jan 29, 2010, at 4:12 AM, Ryan D. wrote:

[email protected]:~$ gem -v
1.3.5
[email protected]:~$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]

I googled around but couldn’t find anything related to this error.
Any idea?

Huh. I’m developing against 1.3.5 as well… if I had to guess, I’d
say that ubuntu changed yet another thing in rubygems and that
affects sing… Dunno. Eric? Any clue?

I get the same thing on OS X 10.5.8

:Users/rab $ ruby -v
ruby 1.8.6 (2008-08-11 patchlevel 287) [universal-darwin9.0]
:Users/rab $ gem list rubygems-sing

*** LOCAL GEMS ***

rubygems-sing (1.1.0, 1.0.0)
:Users/rab $ gem -v
1.3.5
:Users/rab $ sudo gem install rubygems-sing -v=1.2.0
Password:
Successfully installed rubygems-sing-1.2.0
1 gem installed
Installing ri documentation for rubygems-sing-1.2.0…
Installing RDoc documentation for rubygems-sing-1.2.0…
:Users/rab $ gem sing rubygems-sing
ERROR: While executing gem … (NameError)
uninitialized constant Gem::LocalRemoteOptions

1.0.0 and 1.1.0 both worked fine.

-Rob

Rob B. http://agileconsultingllc.com
[email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs