Rubygems & ruby 1.9

Hello,

Is there a 1.9 compatible version of rubygems somewhere? Each I try to
install
it under 1.9 (I use svn’s trunk), it barfs with the following:

I can get around this by using “=>” instead of “,”, I can work around
#funcall
being replaced back by #send but then it gets more difficult.

<— lib/rubygems
<— lib
/usr/local/lib/ruby/site_ruby/1.9/rubygems/custom_require.rb:27:in
gem_original_require': /usr/local/lib/ruby/site_ruby/1.9/rubygems/format.rb:63: syntax error, unexpected ',', expecting tASSOC (SyntaxError) ...ormat.file_entries << [{"size", entry.size, "mode", entry.mo... ... ^ /usr/local/lib/ruby/site_ruby/1.9/rubygems/format.rb:63: syntax error, unexpected ',', expecting tCOLON2 or '[' or '.' ...< [{"size", entry.size, "mode", entry.mode, ... ^ /usr/local/lib/ruby/site_ruby/1.9/rubygems/format.rb:64: syntax error, unexpected ',', expecting tCOLON2 or '[' or '.' "path", entry.full_name}, entry.read] ^ /usr/local/lib/ruby/site_ruby/1.9/rubygems/format.rb:64: syntax error, unexpected '}', expecting keyword_end "path", entry.full_name}, entry.read] ^ /usr/local/lib/ruby/site_ruby/1.9/rubygems/format.rb:64: syntax error, unexpected ']', expecting keyword_end /usr/local/lib/ruby/site_ruby/1.9/rubygems/format.rb:71: syntax error, unexpected $end, expecting keyword_end from /usr/local/lib/ruby/site_ruby/1.9/rubygems/custom_require.rb:27:inrequire’
from
/usr/local/lib/ruby/site_ruby/1.9/rubygems/installer.rb:10:in <top (required)>' from /usr/local/lib/ruby/site_ruby/1.9/rubygems/custom_require.rb:27:ingem_original_require’
from
/usr/local/lib/ruby/site_ruby/1.9/rubygems/custom_require.rb:27:in
require' from /Volumes/Users/roberto/Build/rubygems-0.9.4/./post-install.rb:83:ininstall_sources’
from
/Volumes/Users/roberto/Build/rubygems-0.9.4/./post-install.rb:116:in
run_hook' from setup.rb:1560:ininstance_eval’
from setup.rb:1560:in run_hook' from setup.rb:1526:inexec_task_traverse’
from setup.rb:1342:in exec_install' from setup.rb:1000:inexec_install’
from setup.rb:814:in invoke' from setup.rb:773:ininvoke’
from setup.rb:1578:in `’

On Sep 26, 2007, at 05:50 , Ollivier R. wrote:

Is there a 1.9 compatible version of rubygems somewhere? Each I try
to install it under 1.9 (I use svn’s trunk), it barfs with the
following:

The tracker has such a bug marked as fixed.

Use trunk.

Beta coming soon (this week or next).