RubyGems dans netbeans


#1

Bonjour,

J’ai (encore) une question. Mon Netbeans possède JRuby 1.1.4. Je
diposais en plus d’une version de ruby (1.8) que j’ai déinstallée. Le
problème est que lorsque je crée une application rails on ruby, j’ai
toujours le message d’erreur suivant :
Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please gem update --system and try again.

SI je consulte le gestionnaire de paquets gems, je dispose deja de la
dernière version. J’ai essayé la solution suivante :
http://blogs.sun.com/divas/entry/fixing_the_rails_requires_rubygems en
me plaçant dans le répertoire jruby de netbeans mais en vain.

Comment faire en sorte de disposer d’une console (soit sous netbeans,
soit sous ubuntu) ou les commandes s’appliquent à jruby.

Je pourrais très bien remplacé jruby par une version de ruby dans
netbeans mais j’ai des problèmes de dépendances… et je tourne en rond.

Si j’installe xxx => il faut yyy. Mais si yyy alors zzz doit etre
installé et n’est pas compatible avec xxx


#2

tu travailles avec quelle distribution de linux?

En tt cas, tu dois désinstaller cette vesion de rubygems et puis
télécharger la derniere version de rubygems disponible dans le site…
tu la compile et tu auras alors la derniere version installée… :slight_smile:

On 17 avr, 13:33, Monseigneur babiben removed_email_address@domain.invalid