RubyGems Beta 0.9.0.8


#1

Beta version 0.9.0.8 is now available with:

gem update --system --source http://onestepback.org/betagems

Merry christmas from the RubyGems project!

= Upgrade note

While require_gem was deprecated in 0.9.0, the bin stubs are still
using it (oops!). To get rid of the warnings printed by rake or
other bin stubs simply reinstall the gem. In the next beta ‘gem
pristine --all’ will fix all your gem bin stubs.

= What’s new since 0.9.0?

Lots! Many changes both big and small! Here’s an incomplete summary:

  • require_gem is deprecated and will print a warning. Use gem instead.
  • RubyGems now requires ruby 1.8.2 or greater.
  • gem command changes
    • new gem pristine command
    • new gem outdated command
    • new gem sources command
    • gem uninstall can uninstall multiple gems
    • gem install uses the cache instead of downloading
    • gem install returns non-zero exit code on failure
    • gem install can now set shebang on bin stubs (env or ruby)
    • gem help output now fits in 80 columns
  • now -w clean
  • many proxy installation improvements
  • gem cert impromevents
  • RubyGems is now easier to use as a library.
    • Easier programatic installs
    • Easier inspection of local and remote gems
  • extension building enhancements
  • error reporting enhancements (less odd exceptions)
  • many bugs fixed or closed (0 bugs in tracker!)
  • require now loads .jar files
  • select bug fixes:
    • installing from scratch fixed
    • gem install --force forces
    • installing from read-only location works
    • gem uninstall requires full name
    • gem install obeys GEM_HOME for bin scripts
    • RubyGems now installs on ruby 1.9

For full details, read the ChangeLog.


Eric H. - removed_email_address@domain.invalid - http://blog.segment7.net

I LIT YOUR GEM ON FIRE!


#2

Eric H. wrote:

Beta version 0.9.0.8 is now available with:

gem update --system --source http://onestepback.org/betagems

Merry christmas from the RubyGems project!

Thank you santa.gem!


James B.

“To predict the behavior of ordinary people in advance, you only have to
assume that they will always try to escape a disagreeable situation with
the smallest possible expenditure of intelligence.”
- Friedrich Nietzsche


#3

On Dec 25, 2006, at 15:41, James B. wrote:

Eric H. wrote:

Beta version 0.9.0.8 is now available with:
gem update --system --source http://onestepback.org/betagems
Merry christmas from the RubyGems project!

Thank you santa.gem!

Welcome!

Oh, I forgot to mention, report bugs here:

http://rubyforge.org/tracker/?func=add&group_id=126&atid=575


Eric H. - removed_email_address@domain.invalid - http://blog.segment7.net

I LIT YOUR GEM ON FIRE!


#4

On Dec 25, 2006, at 15:03, Eric H. wrote:

Beta version 0.9.0.8 is now available with:

gem update --system --source http://onestepback.org/betagems

Merry christmas from the RubyGems project!

Since I’ve seen no issue reports, (but a few changes to make the
upgrade saner) I’m hoping to push a second beta sometime early next
week with 0.9.1 coming sometime in the following week.

If you’ve got issues, speak up!

Oh, and file bugs:

http://rubyforge.org/tracker/?func=add&group_id=126&atid=575


Eric H. - removed_email_address@domain.invalid - http://blog.segment7.net

I LIT YOUR GEM ON FIRE!