Rubygems and ~/.gem


#1

I’ve been very happy to see the latest improvments in rubygems
regarding installation of both 1.9.1 and 1.8.x gems in my home
directory, but there are still a few rough edges.
I have not found any configuration to disable the warning that is
issued every time i do gem install about rubygems not being able to
write to /usr/bin and /usr/lib/ruby/gems/...

Changing the line installer.rb:50 to
@home_install_warning = false

Fixed that problem for me, would be nice if that was an option in
~/.gemrc so i don’t have to do it for every version of ruby 1.9 or
rubygems i install.
Now it still seems as if gem cleanup wants to clean up somewhere
outside my home and fails.

GEM_HOME=~/.gem/ruby/1.8 gem cleanup

Fixes this problem, here as well, an option or better default would be
nice.

Thanks for the last release, I love how rubygems progresses,
^ manveru


#2

On Thu, Jan 29, 2009 at 2:26 PM, Michael F.
removed_email_address@domain.invalid wrote:

I’ve been very happy to see the latest improvments in rubygems
regarding installation of both 1.9.1 and 1.8.x gems in my home
directory, but there are still a few rough edges.
I have not found any configuration to disable the warning that is
issued every time i do gem install about rubygems not being able to
write to /usr/bin and /usr/lib/ruby/gems/...

Changing the line installer.rb:50 to
@home_install_warning = false

@home_install_warning = true

That is, sorry :slight_smile: